This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Unbelievably ugly speed curve on Strava

As i mentioned a few days before i noticed this well-known old bug from the Edge models since 8years for sure, today i recorded with 4 devices to prove , something is not good in the Edge's code, on longer rides, RANDOMLY (so not every day, i'm trying to find out is the CLIMBPRO the problem or not, TODAY it was ON ) after 1h, the recording gets corrupted somehow and the speed chart on strava looks like this (NO COMMENT), it is the same segment with every devices, THERE IS NO SPEED SENSOR PAIRED ON PURPOSE (WHICH IS HIDING THIS ISSUE) . i still not analyzed the FIT file, but could be 2 issues imho :

#1: GPS position duplications due to not high enough priority in the code for getting position data from GPS chip in every seconds and if it cant get new position, it is using the last known value , and it makes duplications, and the "distance" datafield has weird steps sec by sec

#2: Any other code issue where again there is no high enough priority for the PERFECT every sec recording (it must be mandatory in every case, any other feature and gimmick is just secondary)

just a remark, a few days ago i noticed similar issue with the Forerunner 965 too (there is no ClimbPro in that, just "raw" recording without any gimmick, with screen off , etc)

If somebody has similira Strava displaying issue, pls let me know (i will later update my post with raw FIT file analysis)

  • today this jaggy speed chart started after 1:15:00 (before it looks like similar than my other devices' speed charts so OK) and lasted till 1:52:00, probably it was the last loaded climbpro segment , after it i went home on downhill (total time was 2:00:00). i will check my other day when i used the ClimbPro, and will write my experience.

  • With your permission, I can pull a .FIT file or files from your account to help  us look into this with you. I will just need a date or two from you to look at rides from your 840 specifically. 

    My apologies on the delay in reply. 

  •  No problem, thank You for the answer, yes, You can pull any FIT files from my account (both from the 840 and FR965 are there) 

    this 2hs long analyzed activity was on 9th May 2023 (recorded with 840 and with FR965 too as always )

    same problematic rides are: 5th May 2023 and 4th May 2023 also (suddenly these three from tha last 1 week...

    and one more info, this bug exist in the 540 also, my friend bought a new one a few days ago, he is participating on the Tour de Hongrie 2.Pro race and his speed chart also such a jaggy after 3hours :

  • so i could ride a 90m+ with the v9.26 outside too on 12th May (but probably You already have seen it on my account), the duplication is there as i supposed, immediately from the beginning for a ~5mins with very dense repeats, then it is stopped, and only there are 3 "invidual" duplications later in the file.  

    here are the duplications with values of the "time relative" datafield which is very talkative

    i still rode without speed sensor on 13th May also (still not raw analyzed but i think it is unnecessary * UPDATE, ANALYZED, BELOW THE RESULT AND INFO), but from 14th May i paired to my Edge 840 too (in the FR965 i already use the speed sensor since 10th May, so only the prior rides are problematic with FR965, as i wrote You in the priv. message)  , i dont wanna more jaggy speed chart on Strava until this bug is not fixed in the Edge 840 (and the FR965 too) firmware.


    btw, there was a GPS firmware update since 10th May on Edge840 (it was 2.37 till 12th May evening for sure!), since 13th May it is already 2.48 (i didnt notice when was it installed... ), in the 13th May ride there is only 1 duplication (which is just more than the expected 0 (zero) if my speed is not 0 (zero), so i'm in move, this 1 pc could be a good sign but could be accidentally too so i have to test more...). unfortunately on 14th May i used speed sensor to my Edge 840 for a 4hs ride for perfect Strava speed chart, so today i have to remove it and check without it again with the GPS firmware 2.48 (but as i wrote, 1 wrong duplication is more than the expected 0 ...)

    My other question is regarding the GPS firmware: why dont we get GPS FW version change log for this Airoha chipset, in the past it was published for MTK chipset (maybe for the Sony too but probably already that GPS FW change log was missing as public... Can we know what changed version by version (for the Edge 840 and for the FR965, i think there are more subrevision depending on wristwatch or cycling device)

  • - Is this still occurring with software version 9.29?

  • without livetrack, it is already (almost) perfect, there are no visible issues on Strava chart(in the FIT file sometimes 1 or 2 but those are not visible on Strava), i tested it a lot with lots of longer rides (3-4hs long), so very promising.

    but in the past 1 week, i had to start to use the livetrack feature for safety reason, and there were lots of jaggy speed sections in Strava, its shape is different than the original issue, so maybe it is some kind of insufficent resources for recording , or similar due to livetrack + climbpro + loaded course with route navigation and recording, unfortunately i am in a middle of a very hard training block and i have/had no brain capacity and time to do further analysis (maybe from next monday). so in the past 2-3 days i had to use the speed sensor again with 840

    check pls my ride (on my account) 29nd May 2023 (with 840, 93.84km,  578m) , and between 45:00 and 47:00 min , there is a problematic section (there are more just i cant analyze it further from my mobile phone)

    thank You for response!

  • check the 3rd June 2023 (i removed the speed sensor for this recovery ride), only used: BT connection with LiveTrack, normal ClimbPro, and the whole ride is full with jagginess... here is the comparison:

    raw FIT file analysis later will be added

  •  today i rode with "BT Conn., Segment (1st try today since unit purchase), ClimbPro, no LiveTr, no speedsensor" and the speed chart ugly again, i am starting to think that the BT connection (the phone connection , and a possible "no coverage" status and no signal and no mobile internet, which is very common here due to weak mobile provider signals in the forests and it halts the connect app and somehow the connection between app and the Edge) is the problem, but tomorrow i will try it again without BT connection but with Segment , Climbpro. the weird thing is that in the past weeks the unit worked good with BT connection but only with ClimbPro and Course+navigation, with the LiveTrack was the 1st problem where this issue appeared again, now with the Strava Live Segments... 

  • I updated the title of my rides on Gconnect, today i had issue with BT Off, ClimbPro ON, Segment ON... I'm getting tired to test it more (so from tomorrow i will use speed sensor until a fix), pls fix it, search that damned issue in the code , why is it frozen for secs and duplicate...