This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

FTP Detection Error

Had this a few times recently. Finish a ride and the Garmin presents me with a crazy new FTP that isn't reflected by the ride data, along with an updated 'Best Power (20 Minutes)' Personal Record.

Can't see any particular pattern. Any fixes? Doesn't seem to do much damage to Garmin Connect beyond being a nuisance at the end of a ride (assuming you press 'skip' and not 'update'!!)

  • Your local support team will be able to gather further information from you and offer troubleshooting. You can contact them using this link.

  • I tried that. Emailed support two days ago and no answer yet Confused

  • We aim to respond to emails within 72 hours, but this can sometimes vary based on demand. Your email will be worked in our support queue, and we encourage users to reach out to us by Phone or Chat (when available) for the quickest response.

  • Thanks for the update. 72hrs has passed, but no response yet...

  • Hi, did you manage to sort this? Looks like something that has cropped up in the past, been fixed and has then crept back in to the FW. One thought I did have - I have recently started putting Edge to sleep at cafe stops (to simultaneously sleep the connected Varia). Saw some mention in a very old post of this upsetting the auto detection so will try the next couple of rides without sleeping. My problem is identical - crazy ftp suggestions and 20 min power records, but all the data during ride on screen and on FIT files after is correct.

  • Hey! No fix yet. Garmin wants some more info from my Edge, but I've been away so will pick up with them next week. I've been stopping/sleeping/shutting down the Edge all the time I've had it and there's definitely no correlation for me between that and this spurious power/FTP extraction.

  • Thanks for fast response. Understood. I don't always stop/sleep/shutdown but I certainly have done it in the past with no issues. I just wondered if some change in the F/W had reintroduced a previous fault (this seems not to be an uncommon occurrence). Against that, looks like 9.73 has been out for a long while, although I've no idea when my unit updated - I don't often plug into pc. I'll try next ride without using sleep function anyway, just to hopefully rule it out for sure. Not likely to be before Thursday but I'll report back if any change in behaviour.

  • So, my ride today I deliberately didn't use stop and sleep at the cafe and I got a sensible auto FTP suggestion on completing the ride. I was using a new Varia unit today but I can't believe that would alter anything. At the weekend I'll do a control test by using stop / sleep again. I strongly suspect a previously fixed error has been reintroduced somehow but next control test should confirm it. Or failing that the faltering old Varia did somehow have some strange effect (less likely I feel). Maybe try a no stop/sleep ride your end too to confirm if same result?

  • I've seen this problem several times recently with my Edge 830.

    I don't generally even pause it during rides, (I do let AutoPause work) but never put it to sleep during a ride. I THINK on one occurrence of this, I did put the device to sleep AFTER FINISHING the ride, and waited till I got home maybe 10 minutes later to let it sync, and only then saw the ridiculous numbers, something crazy number like 1439Watts FTP and 17.27W/kg or close to that.

    Today, it did it again after a century ride, device was never put to sleep but did have some extended autopauses during refueling or removing/adding clothing. It said 1831W and 27.29W/kg. Obviously I chose SKIP so it won't foul my FTP settings, but this is ridiculous. Then it also gave the New Power Record with an insane value. I'll have to go into GC and delete that info... WELL, I don't see it anywhere even after several syncs of the EDGE 830. Don't know if it's going to sneak in tomorrow or the next day or never.

    Thankfully, the actual ride data looks normal.

    I only WISH I could actually produce those numbers, especially at 65 years of age! I'd be way beyond a phenom! It's cool to imagine how it would feel to be able to climb with that power!  :-)

  • Thanks for another input. I thought my issue had resolved itself after installing a new Varia (Co-incidental I'm sure) but no, got another super human power record after a ride this week, with a coffee stop where I actively used the Sleep function. I'll try avoiding the Sleep function for a few rides and see if it repeats but the problem does seem to be rather random.