Touchscreen Replacement & Firmware Update- Issue

Having cracked the screen on my 820 and living with it for many months I finally decided to replace it. So I picked up a screen and digitizer unit from ebay

The installation went fine, I tested the unit and it worked properly. The replacement screen was responsive and all was good. I did not have the double sided tape so did not seal the unit back up and out it to one side.

A few days later whilst waiting for the tape to arrive I decided to update the firmware to the latest version, and this is where my problems began. Following the software update my screen was now unresponsive. Thinking it was some error that could be fixed by re-setting the unit I blanked the setting using the  full reset method

  1. Turn device off
  2. Hold Lap/Reset and Start/Stop
  3. Press and release the power button
  4. Continue to hold only Lap/Reset and Start/Stop
  5. Release Lap/Reset and Start/Stop when the Garmin Logo is cleared
  6. The unit will restart and clear non-vol

This successfully reset my unit. Up comes the prompt that asks me to select the setup language, I can scroll through the languages but the screen is not recognizing the tick selection - basically I am stuck at this screen. Thinking that maybe the ribbon had come loose I removed the screen and reattached it a few times to test but nothing changed the screen does not work properly.

Fast forward a few months I was convinced that maybe I had damaged the screen with my testing so I picked up another from ebay, installed it and again everything worked fine & now that the double sided tape had arrived I decide to seal the unit up. Used the device for a few rides and assuming all was good decided that it must be ok to upload the latest firmware. Guess what? the same outcome as above screen now does not work 

Setting aside my decision to repeat a failed method anyone have an idea why a firmware upgrade is breaking the screen and is there a way to bypass the language selection option so I can attempt to downgrade the firmware? Any other ideas?


  • Hi

    I'm one of those who are going to resurrect the topic... I also apologize first of all. I want to better understand the steps during screen changes and problems with the update, if you don't mind.

    After the first replacement (to replace the original broken screen) you updated the firmware and the problem appeared, right? Even with testing the flat cables, nothing has changed.

    Then you did a second replacement with a new screen and the unit started working again. Here are the questions/possibilities I'm wondering about:

    1) During this replacement, was the firmware the same as the one that caused the problem on the first screen?
    2) Or did you manage to downgrade before the second replacement and then go back to the current version?
    3) Or a third possibility: a new firmware version was released after the second replacement and this update caused the problem with the second one, in the same way as with the first one?

    I'm particularly interested because I have a unit with the same problem. When updating to version 12.70, the same thing happened with the screen. From this point of view, if you tell me that the third option happened to you, I hope to replace the screen on my unit and no longer have the risk of an update ruining the screen, as we will no longer have updates for the Edge 820.

    On the other hand, I still have hope. If you tell me you got a downgrade before the replacement, please tell me how! lol

    I even started a post with the problem and data I've managed to gather so far, as well as what I've already tried. If interested:

    Thank you for your attention in advance.