Garmin 530 will not turn off

I've had my 530 for a few weeks now and this morning I wasn't able to turn the unit on (from sleep mode). I didn't try holding the power button down - instead i plugged the unit into a computer which turned it on. 

I now can't turn the unit off. Pressing the power button doesn't bring up the sleep/power off prompt that it used to do. Holding the power button for 10 seconds triggers a reset/restart so the power button must be physically working. I have tried factory resetting the device with no success. Has anyone else had this issue? I've tried searching the FAQ, these forums, and googling but couldn't find this issue reported by anyone else. 

The unit otherwise seems to be working fine - I can start / stop activities, pair with my phone etc. 

I might try updating the firmware to 5.24.

Regards

  • That does sound like a weird one...  My power button behaves like this:

    1. press and hold for a moment brings up the menu for selecting sleep, alarm or power off
    2. continuing to hold will bring up the incident alert option
    3. continuing to hold even longer will shut the unit down (not a restart but a regular power down)
  • Updating to 5.24 unfortunately didn't make a difference. So now to turn off the unit I need to hold the power button down for about 20 seconds and to restart it i press the power button for a few seconds as per usual. 

    Not end of days stuff but strange nevertheless!

  • This just happened to me.  I found a solution on the forum - simply hold the power button for a LONG time (felt like at least 15 seconds for me), and the unit will shut down.  I was then able to start the unit normally.

  • Thanks Bill, this has been working for me too. However even on restarting the 530, the power button still doesn't bring up the sleep/turn off menu like it used to. So I have to either wait for it to turn off after a few minutes of being idle or force the power off by holding the button. To turn it on, I have to hold down the power button for about the same time and then press it shortly.

    I've logged a case with Garmin support and will post again when it's resolved.