If I power off my Edge while my activity is paused, it stops calculating calories when I turn it back on and resume the activity. Am I missing a setting or is this a bug?

If I just pause an activity, then resume it without powering off, it resumes counting calories no problem. If I pause the activity and power it off (or the auto power off kicks in), it doesn’t continue to count calories once I turn it back on and resume the activity. It seems like a bug in the firmware as there are no relevant settings I can find. Very frustrating as I makes stops on a lot of my rides and really don’t want to create a separate activity for each segment.

  • You may have noticed the thread "Edge 130 Plus elevation accuracy is poor following switch off and on in mid ride" where the elevation feature is crippled (not entirely dead though) after a power-off during pause. There's no setting and Garmin says it's not a bug. You should not expect to be able to power off, or use the auto-power-off feature, just because that makes sense or because it used to work in the earlier model (the original Edge 130).

  • Thanks for pointing me to that. Very infuriating response from Garmin as these are clearly bugs that should be resolved. Auto power off is a default setting, but oh, the device isn't designed to be used that way (WTF Garmin Unamused)?!

    I guess all I can do is make sure the device doesn't switch off, though we'll see how the battery life goes (battery on the 130+ is better than my old 130 at least).