This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Map not syncing

I tried factory reset, re-install garmin connect all on iPad and Samsung s21. Tried tcx , gpx and Komoot upload.I even tried updating from website. My maps are simply not getting transferred to 130 plus. It syncs, says download complete, but I still cannot see course in navigation.latest firmware and device 5 months old. Please help I have a charity ride this Sunday. I am trying to upload route created on ride with gps.

  • The quickest resolution to make sure you have the course loaded for your ride this weekend would be to manually load the file. 

    The 130 Plus is not compatible with .TCX files so you will need to download the route from your preferred website as a .GPX file. Then while you have your Edge connected to your computer, move this file into the NewFiles folder. It must be this folder for the course to be processed correctly. 

    Additional info can be found here

  • +1 on this problem. In most cases, sync from Garmin Connect does not work. In about one out of five cases it does, usually after deleting another course but not always. Noting I have just a few courses loaded on the device, so space is probably not the issue.

  • But what if you want to sync a Strava Route in order to keep the Strava Live segments?

  • Same problem here. I also did a reset of the Edge, still not working. Route shows on Garnin connect  app. I give commend to send it to the device, it says downloaded, but later does not show into routes. Don't know why. And i'd like Garmin bobbleheads give us a feedback about this.

  • Have you reached the "30 courses saved limit"?  This would cause what you're describing.

  • No!

    at least for me having the exact same issue reported. Device has become useless now

  • the fix for me was to ensure the time format was the same on the edge130+ and the App/connect (24hr for me). Then a reset of the settings

  • I use courses extensively on the Edge 130 Plus for mountain biking and the following process never failed me:

    - I create the course on my Windows PC using a tool called JOSM, often starting from multiple GPX tracks I download from Trailforks. I also draw my own segments either directly in JOSM or on a website called GAIA GPS.

    - I export the course as GPX and pass it through the Converter tool on GPS Visualizer, to clean it up and add DEM elevation data. This direct link will take you straight to the Converter and also set all the options I usually enable. You just need to select the GPX file and click on Convert.

    - Download the converted GPX track and import it into Garmin Connect (always working out of my Windows PC). I do not make any edits to the course in Connect, other than name and Average Speed (under Pace Calculator - I set it to 5mph as that's a good approximation on how long it will take us to do the ride, including pauses and breaks).

    - Plug the Edge into a USB port, wait for it to show up in Windows Explorer as a removable drive, then select the course in Garmin Connect and click on Send to Device. Garmin Express will open up and load the course on the Edge. Note that at this point if you look at the Edge from Windows Explorer you should see one or two .FIT files under \GARMIN\NewFiles. If you don't see anything there, then the issue is between your PC and the Edge. As mentioned above, you can also try manually copying the .GPX course directly into GARMIN\NewFiles. When you first turn on your Edge, it will take those .FIT or .GPX files from GARMIN\NewFiles and turn them into a Course in GARMIN\Courses.

    I also I keep my 130 Plus as light as possible, periodically removing all Activities (always from my Windows PC, deleting all files under \GARMIN\Activities) and the Courses I don't need (from \GARMIN\Courses).

  • Same problem here. Strava and komoot are not uploading the maps. I re-install but ... not working

  • If you want some help, try to be specific: what exactly are you doing? Are you using a mobile device or a PC? Have you tried the steps I mentioned above?