wifi sync not working

Running 17.29 beta, but also on the previous software, wifi sync was ALWAYS an issue on my 1040.

I truly cant comprehend how is this possible, to have this kind of problem with a protocol that was developed in 1977....

I dropped a post on the beta forums as well, but I'm just completely devastated with the fact EVERY single Garmin device I owned, had always an issue with wifi.

It's like your TOP feature... "Garmin, your wifi connection will never work, when you need it."  Maybe this should become your selling point?

If I would live in US, I would sue you for impacting my mental health. I cant believe how much time Ive spent on trying to make it work. I feel like I work as your tester full time.

The joy of having a nice bike computer is completely diminished and I'm just constantly pissed off when I finish my ride, as I know for SURE, the ride WILL NOT be uploaded automatically and I will need to do some magic tricks to make it somehow upload.

The reliability is a DISASTER and I truly hate my 1040 for this.

The person/team who is responsible for Wifi in Garmin, should be FIRED and never allowed to work on Wifi topic again, in any company. 

  • Man haha glad that you wrote this…

    I just did a test, disabled Bluetooth ok my phone and started a fake ride… stopped and it synced via WiFi… LOL

    yes the message still shows Sync Failed… like you said. Well I didn’t try it on beta, for quite some time, since 20.19 came out, it triggered me to do some tests.

    so.. it works, it’s just the message that is wrong on non-beta software.. 

  • I'm also seeing this issue on Edge 840 (firmware 20.19), I'm posting here because this thread already got traction and I believe it's the same issue.

    I have router set exactly as mentioned earlier, separate 2.4 network etc. Ever time I run "wifi sync" I'm getting an error "Sync failed". There are 2 clues hinting that it's not a problem of my router configuration:

    1. I made this screenshot on my router's traffic monitor. This is what traffic looks like during a failed sync. Garmin Edge is the only device with access to this network, so it manages to download 24.7KB and upload 46.1KB before failing.

    2. If I completely turn off the device, power it back on and then very quickly go to menu -> Connected Features -> Wi-Fi I can see that sync is already in state "Transfer in progress" (probably triggered during startup sequence) and then, miraculously, changes to "sync complete". So it's the only way for me to get a successful sync, triggering it by restarting the device.

    Feel free to contact me if you have further questions or you need assistance debugging it.

  • Another thing that can cause issues with a router is virus protector if it has one. Another item which is an issue is with certificates. Make sure your router is setup so it can process the link. Not sure what brand of router you have, but make sure you still have the router credentials still setup in the Garmin device. My 1040 somehow had its link credentials get messed up in the 1040 and went through the same bs. Had to delete link and restart from scratch with finding router and then re-entering passcode to get things going. Feel your pain. 

  • I did more testing. I turned off bluetooth on my phone (and bluetooth stayed off whole time) and did following steps:

    1. Turned off Garmin Edge unit

    2. Went to trainerroad and marked incoming workout as outside workout

    3. Turned on garmin edge, workout appeared on Home Screen, so pulling workout using wifi worked

    4. Finished the workout, after saving the activity it was immediately pushed to Garmin Connect and trainerroad, so pushing activity using wifi also worked.

    5. Still having bluetooth off I went to Garmin connect and created new course. Then on Garmin edge I went to connected features -> wifi -> sync now. Message said "sync failed" again but when I went to Home Screen I saw new course there. So pulling courses using wifi works as well.

    I'm not sure what doesn't work. Is it just wrong message after pressing sync now? One thing is certain, message "Sync failed" is too ambiguous and it's impossible to know what's really going on. I don't really know which part of sync is failing, seems like it's not pulling workouts and courses, and not pushing activities.

  • It would be nice if it was just "fixed" - common Eero Mesh system has the same SSID on 2.5 and 5GHz networks... because it's 2024 and it's a mesh system. Every other device from cheap bathroom thermostat to TV to assorted phones and devices can connect, but not an Edge 1040. Just fix it please Garmin.