Notifications during sleep


My watch is currently off during my sleep (not normal but I have a rash on my skin where I normally wear it) and it is set to 'do not disturb during sleep' which I have set from midnight to 8am.

Trouble is, the phone is still vibrating on the nightstand all night and disturbing my wife who is a light sleeper.

To the best of my knowledge the light isn't coming on, but I can't tell you if this is a new problem or not (the vibration is louder on the beside table than it is on my wrist)

Is there something I've missed?

Any help appreciated thanks 


  • Mine just started doing the same thing the last two nights.  I'm wondering if it has to do with the latest update which mine did very recently.

  • My watch also start doing this after the update.

    Too bad when it's a new update and some bugfixes, there's always a new bug

  • Thank you for letting us know there might be a new bug in the v14.20 software update just released.

    Please double check the following:

    - Go to Settings > Power Manager > Battery > During Sleep to ensure you see the sleep window you have set shows correctly and matches what you set on your Garmin Connect account

    - If your power manager is set correctly for During Sleep but your watch is not going into power saving mode at night, what is the behavior you are experiencing during the middle of the night that demonstrates the feature has stopped working?

    Thank you.

  • Hi Chris,

    On my Solar Instinct when I go to Settings > Power Manager >   My only two options are Battery Saver and Power modes.  I don't see how to check my sleep window on the  watch.  I do see it set in my Garmin account.  That said the problem shows up to me as follows:  Previously during my sleep window, phone on silent as well, nothing would come through on either phone or watch.  Since the update, During sleep window, phone on silent both watch and phone alert me of incoming alerts.  Seems strange.  Thanks.  


  • I agree, there may be something strange.

    I apologize. I meant to say, check your Settings > Power Manager > Battery Savers > During Sleep menu.

    Please double check that menu, if enabled, you will see the same sleep hours matching what you set in your Garmin Connect Mobile APP when you added your watch the first time. Thank you for double checking.

  • My watch has during sleep turned on and has the same 'bedtime' as set in my connect app.

    It basically vibrates everytime a notification comes through, something it should do normally, but not when on do not disturb!

  • Hi Chris,

    My watch showed battery saver during sleep - OFF.  When I turn it on , it does show the correct hours.  I'd like it to monitor my sleep so do I want battery saver during sleep on?  Is it possible the update just switched this setting?

    Thank you,


  • Thank you for monitoring it another night. It is possible the software update changed it back to OFF but it should not have which is why I am hoping to get to the bottom of it. Thanks again for double checking and testing further.

  • my apologies I was looking at the do not disturb under the system menu - that shows the correct sleep times, but I can now confirm that the 'during sleep' part was turned off, and I have now turned it on and it too now shows the correct sleep time...Fingers crossed

    however, i dont need it to conserve power during sleep, just to stay silent!