Navigation Not Working - Distance Always 0 (Zero)

due to problem with EPO, in my case I delete everyday, do you have a widget or app to delete EPO.BIN of our F5X?

  • Why do you delete everyday? If you have a problem, it's better to solve it than work around it.
  • hi Philipsshambrook,
    mainly due to when use the navegation, generally fail (distance 0 to next waypoint).
    when this appens, i connet my F5X with PC and delete EPO, then synchronized F5X by WIFI, it works again. I really do it every two or three days.
    Yesterday I used it connected to the InReach and failed, after erase EPO, ..... I used it without InReach and it did not fail again, it is possible that the problem is caused by the InReach Mini
    on the other hands, I am using the FW 12.81 Beta

    Maybe the problen are FW 12.81 with InReach Mini
  • mcorrea the EPO file should have nothing to do with navigation on the device.


    Unfortunately I can confirm this. Doing a factory reset and deleting EPO.bin from the device doesn’t solve the navigation problems on my F5x. Distance remaining stays fixed at 0m and heading indicator keeps pointing to the start of the route. (When using walking activity and navigating to a saved location)
  • Garmin-Heath, When you delete the EPO, synchronized F5X by WIFI, the F5X works fine one or two days and then the distance issue (0m) fails,
    in this case, to fix it I repeat the procedure.When I read the EPO link that you sent me really, it should not have anything to do with the problem ,but delete it for some reason if it works. thank you for being attentive, when it happens again I will contact you,
    Puustinen, you pair with InReach? and I have also noticed that what most fails is to use walking activity.
  • The problem again, the same solution
  • As the fenix 5x has no turn by turn directions again in follow course mode...I followed mcorrea's advice... I deleted EPO.bin ..synced to WI-FI .... ever since.( well over a week)... turn by turn works perfectly for me.... EPO.bin is back... and I've no problems with distance to next running 12.40 software.
    Deleting EPO.bin worked for me.
  • since I send my EPO.BIN to Garmin team last week, I don't have a issue today. tried this tomorrow, but now no issue
  • I can confirm that plugging the watch into the computer via the USB cable, and then unplugging it, results in the navigation feature working as advertised. Running Garmin Express doesn't make any difference, as the watch navigation features work just fine either way once the watch is plugged in and unplugged. Although the navigation features work after the plugging and unplugging exercise, I have to do it again in order to get the navigation features to work properly if I power off the watch and then power it on again. The EPO.bin file doesn't have anything to do with the issue or the solution, and it appears to me that it's actually the plugging in of the watch into the computer in order to delete that file that results in the temporary fix of the navigation problem...temporary because once you power the watch off and then back on again you're back at square one.
  • Unfortunately I can confirm this. Doing a factory reset and deleting EPO.bin from the device doesn’t solve the navigation problems on my F5x. Distance remaining stays fixed at 0m and heading indicator keeps pointing to the start of the route. (When using walking activity and navigating to a saved location)


    I'm having constant issues, which I resolve by deleting EPO,BIN . I don't even bother reconnecting to PC after that , as it seems that the file gets created as soon as you use GPS (not sure how, but it isn't on the watch , I connect to GPS and it's then back) my routing will work once or twice and then I have to delete EPO.BIN again. :mad: