Fenix 5+ Running start point change

I have had an issue with my Fenix 5 since the start of the year - wondered if anyone else has this issue, or if anyone had solved it.

Effectively, my Fenix 5+ changes my route I run after I save it. This is shown by the green start pointer moving along the route and the route doubling up at the end to make up the lost distance. Overall, the time and the distance remain correct. Below screen shots show this - I pushed the start and end button at the same spot; yet it then shows the start point about 300 yards along my route.

Through trial and error I have worked out that this happens after I save the activity – when I am doing an activity I can see on the watch I have an accurate GPS lock and that at the start of an activity it drops the start pin in the correct location; this is also still in the correct place when I approach the end. It is only after I stop and save that the route changes. This happens before the watch syncs with my phone.

This does not happen on rides or walks. Looking back through my activities, this first happened on the 20th January.

I've tried different GPS constellations, GPS soak and EPO refresh (although i am sure its not the GPS as the lock/positioning when I start and during is accurate).
I've also tried soft and factory resets; updating all the tracking based settings and I have no privacy Zone.

I've raised this with product support (three times) and am still waiting to hear back. To say its a pain in the a** is an understatement. 

Anyone else had this or simiar?

Parents Reply Children