Update 19.30 - Battery runs out in a short time

With this update, my Fenix 5 X Plus loses almost 20% of battery in one day, after using only the GPS for 16 minutes and no PulsOx at night.
Without this update it lasted much longer. To lose a 20% it had to be at least 2 intense days of activity. I think there is a bug in the battery life.
Can you give me some advice?
Thank you

  • Battery drain issues shortly after an update are often solved by just switching the device off and back on. If that does not work, maybe a reset back to factory settings works; see: Resetting All Default Settings.

    And if that fails, and your watch is getting on in years, it may be time to replace the battery. My standard disclaimer is: only do that if you have a backup watch, because you can ruin it, are comfortable repairing small electronics, make sure you obtain a good new battery, are very very very careful removing the old battery, same for fitting the new one, and for replacing the gasket, and don't get the watch wet afterwards because you can't assume it is still waterproof. 

    But the best option is contacting Garmin for your options for an out of warranty replacement, which is not free but way cheaper than an new watch. 

  • If a reboot doesn't help, then...

    When you reboot it, does it get stuck a long time on "loading maps..."?  If so, go read the recent thread here about maps not loading properly.  As per my post in that thread, I had to reload all maps to get around this - and it was hurting my battery as well.

  • but in the last time I doesn't used maps.....

    There are some problems in some sensor?

  • What Docau probably refers to is another a problem, with the maps. If you turn off your watch and then back on again, normally it will show "Loading maps" for a minute or so. But If "Loading maps" stays on the screen for more than 10 minutes, you may have that problem. 

    To help find the cause of your battery running down fast, you can remove watchfaces, apps and widgets that you installed from the CIQ store (if you have any of those). Then reboot. Updates can contain changes to CIQ which affects CIQ apps and watchfaces on the watch, sometimes making them.consume more power. Later, you can reinstall them one by one.

    Or do a full reset back.to factory settings.

  • The maps problem can also cause higher than normal battery draw, even when not using maps.  And it's an easy one to tell if you're affected by (based on the power cycle time - anything more than a minute or so and you definitely have a problem). However I agree it's just one of many things that could be the cause.

  • well, then it means that I'll have to find the time to reset and reinstall everything.... hoping to solve the problem!
    What do you think is the best reset procedure? Through the clock menu or with the key combination? (remind me how to do it this way?)
    A thousand thanks

  • I have the same issue after this update. Must be something wrong with the update.

  • I don'r have any battery issue with this update (19:30), so I don't think there is a general issue. If the already posted hint to switch the watch off, wait a minute and switch it on again, doesn't solve your issue, my recommendation is to remove ALL Connect IQ apps, check the battery life and then install one after the other. The only battery issues I had with my Fenix 5+ in more than 4 years were caused by 3rd party apps.

  • Across numerous devices there is an issue that eats batteries and has been around for quite a few iterations of the firmware 

    my 5s plus suffered from the same issue, I even bought another one on a well known marketplace and same issue what are the chances of that

    i have done numerous resets, formats whatever you want to call it and even replacing the battery with a new one didn’t help 

    all of you that say it doesn’t happen for them must have a different internal configuration hardware or software as there is definitely something that goes into tailspin and eats battery could be gps, heart rate pickup it even does it for devices with no 3rd party apps

    it has been reported on many forums, I was hoping that Garmin would have sneaked the fix into 19.30

  • hello everyone I did the total reset by deleting all the applications. I then reinstalled them and saw no improvement. then I came up with the idea of ​​changing the third-party watch face…. done!! the problem seems solved. the watch has returned to normal consumption. now i have installed the digital one by default and everything seems to be fine