BUG: Garmin Coach not advancing on lap press

I've been using Garmin coach for a while and a problem has shown up after a recent update. When it reaches the end of a lap, at times you need to press the lap button to move forward. For example, on Hill Repeats it may wait for you to press the lap button when at the bottom of the hill and ready to ascend.

Occasionally, it will not advance the screen. My watch will buzz as usual to indicate it has moved on to the next phase of the training program, but the screen will stay the same. Repeated presses give me more buzzes, but the screen won't change. However, if I stop the run and restart it, it will change the screen to the next lap. If I got impatient and pressed the lap button several times trying to get it to advance it will jump to the lap that corresponds to the amount of lap presses. By then I may have skipped a large part of the program.

I'm happy to provide logs next time this happens, please just point me to a howto to exctract the logs.


  • Before hiting the lap button after the warm-up (there will be a red arrow showing on the lower right side of the Fenix display), enter "Menu" (long press on left side, center button) -> "run settings" -> go to "manual lap" ("down" or "up" button on left side) -> enable . This solved the issue on my Fenis 5X.

    Note: there is an "auto-lap" and a "manual lap" in the settings. Do not confuse them. If unsure, enable both options.

  • Thanks for providing an answer to half year old thread! It's odd that a setting would need to be changed, this has always worked correctly, and in fact has only happened 3 times. The problem is not consistent. At any rate, I just ordered a Fenix 7. Thanks again for the response.