This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

fēnix 5x Plus very slow

My watch stopped working well since about 2 weeks and i hat to switch back to my good old fēnix 3.

The main problem is that everything is super slow/laggy. This is everywhere on the watch settings, activity menu and so on.

For example my watch needs four days in real for 24 hours on the screen.

On my watch is no 3rd party watch face and no connection to a smartphone.

Could that be a software problem?

Things that i have tried are:

  • backup all my files
  • update to newest beta 18.42
  • delete all files and do a factory reset in soft and hard style
  • backdate to 12.71 and then update to 13.00

This is how it looks like in realtime and not slowmotioned.

My actual system versions are:     Firmware: 18.00

GPS 2.70 (!)

Wi-Fi 4.01

CIQ 2.4.5

BMX 0.2.4

WHR 20.03.32

ANT/BLE/BT: 6.15

Sensor Hub: 2.41

Hopefully i thank everyone who helps to make my watch work fluent and well.

  • I am currently using Fenix 5 Plus, running a FW 18.00 

    GPS: 2.70
    Wi-fi: 2.50
    CIQ: 3.2.8
    WHR: 20.03.32
    ANT/BLE/BT: 6.15
    Sensorhub: 2.41

    So the differences can be because that you are on a X-version. 

    Have you tried to disable Wi-Fi?

  • How can i disable Wi-fi? Since i have the watch i never used it.

    What do you mean with X-Version? Mine is a f5x+.

  • I simply meant that the Fenix 5+ and the Feinix 5X+ are not the same watch and therefore the the reason for the difference between the CIQ and the Wifi versions. 

    It could also be that you have downloaded and installed the wrong FW. 

    But you should really start trying to disable WIFI on the watch and see if that makes your watch faster.

  • You are using the Wifi version which came new with the latest beta 18.42 on the older firmware 18.0, this might cause trouble.

  • I cant disable Wifi because it is not set up.

    This is the answer of my watch when i try to enable.

    Set up Wi-Fi using Garmin Connect Mobile or Garmin Express

    The problem started before i updated to latest beta 18.42.

    So i don't think this is the problem.

    Is it possible to backdate the Wifi?

    All the versions i tryed aren't working.

  • You could try to go all the way back to fenix 5X Plus software version 17.71 Beta or 

    use the SystemBackDate folder for version 17.30

    After going back to e.g. 17.71 then upgrade to version 18 using  Garmin Connect the normal way.

  • I tried:

    • backdate 17.71 an then update 18.00
    • backdate to 17.30 and then update 17.71 > 18.00

    There are no changes the watch is slower than every snake.

    Maybe some other ideas?

  • It looks as if the watch is doing something resource intensive in the background, like loading maps, syncing files, fixing storage issues, calculating a route or writing RAM dumps. 

    I suppose you already did a reset to factory defaults with full erase of data? Still it is worth checking if the folders that contain files that are synced to Connect are empty, just to make sure no corrupted files are in there: Activities, Monitor, Sleep, Metrics. It is interesting to know if the watch crashes all the time (then you will have a recent RAM.TXT in the Debug folder). 

    Is it also slow when you do a full reset to factory defaults +  delete (again...) and run it without setting it up on your phone (leaving Bluetooth disabled)? 

  • I have the exact same problem and can not find a solution. My Fenix 5+ is taking 8 seconds for each tick of the second hand. Did a complete hard reset, even replaced the battery thinking it wasn't getting enough power, but all to no avail. On firmware 18.0