MTP issues with Fenix 5 Plus on Debian

Currently running firmware 13.00, I tried to copy new mp3 from my Debian box to my Fenix  plus.

With jmtpfs I was previously able to mount my watch as a local drive and copy (although slowly) my files. Now I can still delete files, create folders, rename items, but every time I try to copy a file, I get an input/output error.

mtp-sendfile doesn't perform as expected too : even if I choose a destination filename, the file will be copied with the same name as the source file.

I tried to reboot the watch and the computer, tried different versions of mtp-tools and libmtp, and also tried on another Debian computer and experienced the same troubles.

On Windows, the watch seems to perform OK

Anybody else experiencing these issues ? Have you found a solution ?

  • Hi

    After countless tries, it appears that the input/output error has something to do with subfolders.

    When using command lines, it is possible to copy an audio file to the root of the /Primary/Music/ folder.

    But there's no way to directly copy audio files in any subfolder, and this is the same thing with any software that uses the libmtp library.

    Since none of the mtp-tools seems to be able to copy files to a subfolder and they all seem to rely on the filetype for destination, I guess that is the expected behavior with this lib.

    Luckily I can chain a cp to the /Primary/Music/ folder, followed by a mv to the final destination. This slows down the process by a lot but at least it works.

    I'll take a look at the libmtp changelog to understand why the direct copy to a subfolder used to work before version 1.1.16.



    Copying music to the /Primary/Music/ folder works randomly (about 30% success rate so far). Sleeping the script between each file transfer seems to help but I have yet to find the magic recipe.

    I tried different versions of libmtp and jmtpfs and the results continue to be as random, but with a similar success rate every time.

    Retries are not an option either because even when the transfer fails, a 0k file virtually appears in the directory and will only disappear after the watch is disconnected nand reconnected.

    MTP on this watch is the stoff of nightmares ! Please, Garmin, I beg you, please allow mass storage support on all of your watches. At this point, I'd be willing to replace my otherwise amazing Fenix 5 Plus for a future Fenix 7 for this feature alone !

  • Hi,

    On Debian 12.4 I must unload the garmin_gps module before using gmtp:

        sudo modprobe -r garmin_gps

    Andit works fine after that.

  • Maybe gio is worth a try if you did not already try it. On Ubuntu, it works well for filetransfer from fenix 6 and 7, although I don't know how well it transfers big/many files to the watches. Fenix 5 does not differ from the 6 or 7 when it comes to MTP,  as far as I can recall (my Fenix 5 Plus is gone).