Fenix 5 Plus Compass Stopped Working

I’m on my second Fenix 5Plus with compass problems. The first watch was returned to the store within 60 days of purchase and they swapped it out. Now I’m 10 months into the second watch and the compass and altimeter have gone haywire. I’ve spent the last three weeks on chats trying to resolve the problem and I’m getting nowhere. 

How many people are having this issue. Am I just that unlucky? I mean Garmin is synonymous with direction and therefore you’d think they could get the compass to work. 

I’d hope someone from Garmin reads this and actually helps me with my problem. For what the watch costs, I should be able to depend on it to tell me directions.  With this not working properly, it makes me wonder what else is not correctly recorded by this device. 

  • Yes, I have a problem with the compass on 5x plus too. It simply stuck in the same wrong direction when watch is in horizontal position. Calibration in 90% fails, sometimes passes, but it doesn't change anything. Still have no idea what to do with this - rebooting and updating to the latest firmware (9.0) didn't help. Perhaps this is hardware problem - I'll be happy if I'm wrong...

  • same here with me..
    after about 9 months of use, without problems on the compass (and its calibration) it stopped working. It now points North at "9 O clock" regardless where I turn the watch. Calibration fails 100% of the time. I am trying to contact the support service to see what they can do. I however lost faith in this company honestly. As far as issues with electronic devices are comprehensible the fact that these watches are so expensive makes have less-to-zero tolerance for such issues.

  • This is quite "funny" you mention this - because yesterday evening I took my Fenix 5+ to find NE because of the Perseid meteor shower - but the watch simply didn't give me the proper direction of North (-East).

    I decided to find my old scout compass instead. 

  • Have you tried:

    Hold MENU.

    A) Select Settings > Sensors & Accessories > Compass > Calibrate > Start.

    B) Follow the on-screen instructions.

    TIP: Move your wrist in a small figure eight motion until a message appears.

    I am going to try this a bit later today.

  • I also had a problem with the compass on my F5+, I first noticed the orientation of the maps was all over the place when following a route. However this only occurred at very low speeds, I assume when moving fast enough, the GPS movement overrides the compass.

    When I checked the compass widget, it was completely stuck at NNE (20-40 degrees) through a 360-degree turn. I did notice, however, when turning the watch on a different axis (turning it upside down for example), the value did change.

    I tried the compass calibration, but this failed every time. I have now sent this unit to Garmin for a replacement for a different issue (faulty HR sensor), so I can't investigate further.

  • Same problem here. Exactly the same. North stuck at 10 o’clock. But does move when I tilt the watch. 18 months old. Had the problem about two months now. 

  • Does anyone get a discount code to buy another Fenix if your watch its out of guarantee? I tried to send a request for the same problem but my Fenix 5 doesnt show on the web to select the watch related to the issue.

  • My Fenix 5x plus compass works well at the moment, but has displayed the same issues described here in the past.... My Fenix 6x has a dodgy compass, the temporary fix (known bug) is to change to magnetic North and choose 000 declination for the UK (depending on where you are in the world)maybe you can try it. 

    It kind of works now, but i wouldn't upgrade to a Fenix 6 expecting the compass to work better. 

  • Does someone find the solution for this problem? Is it worth sending the watch for repair?

    Same problem here, 99% of the calibration attempts fails. My compass shows only from 185° to 210°, and if I move it vertically I can show other measures, but not possible to calibrate it.

    Is there any troubleshooting tool for PC or something like that? Thank you all in advance.

  • I haven't found any solution. Was not able to replace the unit, so just live with that (