This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Course updates too large to fit device

Today I had a no courses nearby error. On returning home I've connected to Garmin Express which says there are a bunch of map updates, however it says the updated courses are too large to fit on device.

It suggests to choose regions that I want only, however everything is greyed out and not selectable, meaning I cant do anything and cant get any courses on to my device! Any one solved this one?

Top Replies

All Replies

  • I have sent you a private message.

  • I have same issue s20 going insane with useless Garmin tutorials

  • I have sent you a Private Message.

  • My Approach X40 wanted to update all 3 regions all at once. and it continually fails at about 70%. I cannot deselect them to see which one is failing as I don't need all the golf courses in the world. I think it might be too large to fit. I think the older versions of Garmin express allowed you to deselect the courses you don't want.  The error leaves the watch in a state of "missing golf courses" and then you need a full factory reset. Any suggestions?

  • Since you are still having issues, please reach out to your regional Golf Product Support team. We would be happy to further assist. 

  • Did you ever find a solution? I contacted garmin and followed all there links and reinstalled Garmin Express multiple times. Rebooted the computer and used both a Windows PC and MAC I still get the same error. 

  • Why doesnt GARMIN-Rob answer so all can read the answer???? I think many customers are in the same position. Very dissapointing.

  • Hi Rob, I did solve the problembut it took me at least 5 hours of trial and error.

    Here are the facts that I will also communicate with the forum:

    1. I own an Approach 4S. Had not used it for some years so I knew it needed to be updated.

    2. I tried to update it with Garmin Express (latest version) on a Laptop (new), PC (old) and a brand new Imac. None worked. All computers realised I had connected a hard disc but Garmin Express did not understand it was connected.

    3. After consultations with tech support I was advised to format the watch on a PC, not a Mac.

    4. I did and then Garmin Express found it and I could update watch software but not update Maps. I guess it was due to too small memory on the watch to download all 3 continents data. I could not pick only Europe. I was stuck. This was on my old PC.

    5. Did another test on my new Imac and suddenly I was asked to what part of the world I wanted to update. Picked Europe and I got it updated!

    6. Hard work and a lot of rage I could finally relax.

    Gee I wish I had been helped in a better way. Anyway I hope this will help someone.



  • Hi Thomas,

    After some tries myself with updating maps/courses on my S4 from a PC, I saw that the packages that were part of the update was exceeding the 30 MB total of the watch, and the 18.8 MB free space I had (the only available update was worldwide and it was over 30 MB).

    Did your apprach, and started my old Mac. Needed to re-install Garmin express, but after that, I got the option (only option) to update the Europe, Asia and Africa maps/courses, which worked like a charm. Thank you for your post, which solved my issue.

    Best regards,

    Richard Hellstenius

  • My problem turned out to be done hidden files windows had created on the watch. I think perhaps from disconnecting it whilst it was in the middle of doing something. I deleted those and it was all good again. Might be something to check for.