Montana 700i randomly rebooting or shutting down.

So I know this is yet another random shutdown question but please bear with me. Montana 700i has been glitchy before but never so chronic. Since update yesterday when it is in the cradle it cannot stay on for more than two minutes. Device cycles or shuts down for extended period before rebooting. Device is totally useless. As I mentioned it has up to date software and maps and does this endless cycle of reboots whether navigating or just switched on so I can see the map. Cradle is OEM cradle. Mounted on BMW motorbike with stable direct power supply. Any ideas - factory re-set etc? Please let me know. 

Top Replies

All Replies

  • SD card installed? Apparently that causes issues as device cannot read multiple maps larger than a certain size

  • Hey, no, no SD. Did a factory reset. Will try it out during the week. Expensive bit of hardware that has never really worked correctly. 

  • God knows. Its a bug that they don't want to acknowledge.

    I've a brand new one bought from OS last week here that was doing it while being set up in th house having never ever been used!

    I couldn't start setting it up without having done the19.20 update otherwise I would love to have tried it to see if that's the actual problem.

    I'm going to not update the replacement for my bike when it gets here later this week. Shame GE won't let you just use the SD card/maps from another device despite it being a genuine Garmin one so you HAVE to update it BEFORE it will you download the maps through the device. Its a joke.

  • Hello, if you have a Montana and are experiencing shut down issues we would ask that you contact Product Support directly for assistance with your device. We take each customers shut down issue on a case by case individual basis as they may not all be the same exact cause. There are many different customizations for these devices that each customer can set so it is important that we gather that customers information and usage details. 

  • With the greatest respect Leslie - this is much more than a customisation issue.

    This has occurred ONLY since the last two software/firmware updates.

    The latest for me was on a BRAND NEW 700i device with absolutely NO changes other than the forced update to 19.20 that GE demanded before I could activate it. A device that had never left the table where the laptop being used was. NEVER put into a cradle.

    Garmin have swapped my original device which NEVER suffered this issue before the latest updates.

    It then happened to the replacement refurbished device sent as a replacement.
    It then did it after installing the thicker rubbers to the mount that Garmin sent.

    It then did it after installing a BRAND NEW mount that Garmin sent out.

    It then also did it on a 700 sent to me by mistake this week. One that never left the table next to the laptop.

    I’m currently waiting the UPS shipping  label to return that so the correct 700i can be shipped to me.

    Garmin then want to know how that one functions.

    I already know the answer to that but hey, they want to go through all the motions, etc.

    I have video of rebooting, freezing, screen randomness, etc.

    It is not “user error”.

    This is an issue either with the software, firmware or the device being able to function due to poor processing speed/lack of memory.