GPSMAP 66i 6.30 screens corrupted by undead menus...

Updated the firmware to 6.30 yesterday.

Access an option from the menus, the option screen appears and the underlying menu keeps appearing or else randomly covers the sections of the screen. Tried turning off and on several times. Seems unrelated to data (waypoints, tracks, etc.) on the device and something far more fundamental.

Waypoint Averaging

The Waypoint Averaging screen disappeared, the menu reappeared and then the "Sample Confidence" portion of the Waypoint Averaging screen flickered in and out of view as it was updated.

Navigating between fields on a screen with the arrow keys produces a weird mix of the underlying menu and the screen you're using. Below is an example using the Waypoint Manager to view a waypoint.

Note the presence of the underlying menu mixed with portions of the waypoint screen. Parts of the waypoint screen only become visible as you navigate to them with the arrow keys.

Unless Garmin offer a fairly rapid solution I will be going back to 5.90 (if I can find out how) until notified this issue is solved.

- Carl.