Speed up map rendering, scrolling and zooming

Hi! 

Are there any plans to speed up the map rendering? I had a GPSMAP 64 previously - while it was not as fast as a phone when it comes to it, the map rendering lag was acceptable. I frequently zoom in and out and scroll the map to investigate what features are nearby - but the rendering is very very slow :(. The map is one of the most important features of the device. To make the experience usable the lag has to be reduced drastically. The first time one scrolls with the arrow keys the ui has some "inertia" it takes a while to start moving ... often I get the feeling the device is stuck for 1 or 2 seconds before something changes on the screen. Because of this, I often get my iphone out and use google maps ... which defeats the purpose of using the Garmin. 

Are there any settings / options I can tweak to speed this up? and more importantly are there any plans to optimise / speed up map rendering? 

Thanks a lot! 

Cheers,

Cosmin 

  • You can submit a feature request/suggestion here: https://www.garmin.com/en-US/forms/ideas/ The more people who complain/suggest, the better the chances that something will change.

    I don't know of any settings that can speed up rendering. You might, however, want to take a look at what maps you have loaded and which ones are enabled. I rather suspect that having a lot of maps/imagery (BirdsEye) enabled affects the rendering speed. If so, it would likely affect zoom in particular. Not all maps have data for all zoom levels.

    Although there is no reason to suspect that third-party maps are worse (or better) than Garmin cartography, you might try disabling any third-party maps you may have loaded to see if has any effect.

    Finally, if any of your maps are on SD, this will likely slow rendering for those maps.

  • Few thoughts to help :

    1. Make sure you only have those maps "enabled" that you need for the particular activity you're doing. This can be managed using the various profiles. For instance on my device, for "Boat" profile...I have only the Bluechart enabled, with any Topo/land maps disabled. In "hike" mode, I have Bluecharts turned off, and only my Topo map enabled. The unit by default enables all maps installed simultaneously, which may reduce rendering performance.

    2. In map set-up, there is a map detail control. Having this on high or highest significantly affects rendering speed. Setting it to normal helps greatly...though of course you need to be aware of the drop in detail at a specific zoom level.

    3. If you can, and there's space, install the map on the device itself, not on a SD card, this should result in a read-speed boost for the map.