Troubles sendind tracks from Wikiloc App to GPSMAP 66i


I have a Garmin GPSMAP 66i, and have been a subscriber to Wikiloc's “premium” account for years. Since I bought this Garmin I use both simultaneously, for example: I choose a track that I want to do on the Wikiloc IOS App, and transfer it to the Garmin device.
For this to be possible, the first time I had to pair both accounts, through the Garmin Connect IQ App, in addition, of course, to pair the Bluetooth of the GPS with my cell phone.
Well, the last time I did it about three months ago, and a week ago I tried to do it again. I wanted to transfer a track from the Wikiloc App to the GPSMAP 66i, but I couldn't.
What's happening: I choose the track on the Wikiloc App on my cell phone, click on “Send to your Garmin”, the message “Ready to Download” appears; I open the GPS, go to the Connect IQ tab; I open Wikiloc on the GPS device; the programs connect to each other, the accounts are recognized; so I click on the “Download Track” button on the GPS; then the download starts, but it never ends. You spend hours and hours alternating screens with messages: “Downloading Track” and another warning that the download time depends on the speed of the internet connection.
- Garmin is up to date and in sync.
- My internet is from reasonable to good, and before the trails went down in 2 or 3 minutes, at most; but this week I left it for two whole nights, and nothing. Still I tried on two other very good Wifi networks, and it didn't work either. In addition, it does not seem to be a problem with Wifi or Bluetooth because yesterday I downloaded maps / images from the “Birds Eye” quickly and without a problem.
- Still, on Bluetooth I have already clicked on “Forget this Device” several times, to make a new pairing, and it also didn't solve it.
- I logged out of the programs and logged in again, without success.
- Then I uninstalled all the Mobile App (Garmin Connect; Connect IQ; Wikiloc), then reinstalled and re-paired everything: programs and Bluetooth. I did it all twice and nothing ... still no result.
In view of this, my meager knowledge has run out, and so I ask for your help ... Has anyone had this problem before? Do you have any suggestions for what else I can try?
Thanks in advance.