Troubles synchronizing tracks with web portal

I cannot get the locally stored track on the 66i to synchronize with the web portal. With the inRech SE, inReach Explorer and inReach Mini it was easy: Simply synchronize it via "inReach Sync" at any time and the rough track from LiveTrack (Iridium) with 10 minute intervals would become very detailed as the track stored locally on the device would be transferred to the web portal and merges with the LiveTrack data. Done!

Now I do a tour with the 66i and back at home...

a) I have WiFi connectivity and assumed it would send the track from the device to the web portal automatically. Nope...
b) I connect the device to my phone via bluetooth and successfully synchronize it via Garmin Connect. So I assume this will send the track from the device to the web portal. Nope...
c) I connect the device to my computer via USB and synchronize it with Garmin Express. Again... assuming this will send the track from the device to the web portal. Nope...

What am I doing wrong?

The only way getting the track from the 66i to the webportal is manually importing the .gpx file. This creates a second track (not merging with the LiveTrack data). The only track information it contains is the distance (99.97 km). Zero other information (time stamps, elevation, duration, speed, ...).

By the way, the manual import only worked once. Now the exact same file is - accoring to the web portal - "Unsupported Media Type". So I can't even do further testing.

I'd be thankful for any support!

Simon