Two of previously my assigned clubs missing on the S40 display and will not now re sync with the CT10 showing pairing failed

Hi, Can anyone help.

I have a new Garmin S40 and I also forked out for the full set of the CT10 sensors which I have had for 10 days or so. I synced all 14 sensors to my clubs and had a test run last Saturday and all seemed good.

For some reason the 7 iron and 3 wood are now  missing as an option on the S40 watch , I tried to resync the two clubs and sensors but it repeatedly shows "paring failed".

I spoke with Garmin support who said it might be the batteries have run out ( I would hope not after 10 days ), they Kindly  sent new batteries however this hasn't resolved the issue and the two sensors will still not pair.

I looked at the Garmin Golf app and all 14 of my clubs are shown in the app but as stated earlier the 7 and 3 wood are not shown on the watch when you enter the watch golf settings and then club sensors, just not there.

Within the Garmin Golfapp I considered removing the 3 wood and reinstating it ( can this be done ? ) however when I tap the edit and then remove option it warns me the do I really want to remove the 3 wood as the action cannot be undone .

Anyone had the same issue and any ideas how I can get my 7 iron and 3 wood reassigned. Grrrrrrrrrrrrrrrr, annoying, if not resolved soon the technology will be taking a test flight !!

Cheers Rich. 

    

Parents
  • Hi Rich,

    I am sorry for the bad luck with 2 of your CT-10 sensors. Since the new batteries put into both CT-10 sensors did not resolve their ANT+ pairing issue back to your watch, they are defective. Please contact the same regional support to have them replaced with new ones. 

    In the Golf APP, it isn't a permanent removal that cannot be undone but a warning message to give pause for those not intending to remove them that may have hit a wrong option in the menu.

    - Chris

Reply
  • Hi Rich,

    I am sorry for the bad luck with 2 of your CT-10 sensors. Since the new batteries put into both CT-10 sensors did not resolve their ANT+ pairing issue back to your watch, they are defective. Please contact the same regional support to have them replaced with new ones. 

    In the Golf APP, it isn't a permanent removal that cannot be undone but a warning message to give pause for those not intending to remove them that may have hit a wrong option in the menu.

    - Chris

Children