Golf Shot Analytics not importing .csv from Garmin App

Help Please...
For some reason I can't import todays Range session into Golf Shot Analytics. Error msg says "The import file is not valid. Are you sure it came from Garmin R10 Launch Monitor?"
And yes, I'm sure.
And no, I haven't changed format... I had trouble on Saturdays session too, but somehow it worked after a couple of downloads...
What am I doing wrong? Is there a speciel sequence to this??
What I did was...RTFM...and followed it: From the Garmin App; Share/export via email to myself. Copy from email into dedicated folder. Import into Golf Shot Analytics from said folder...but alas?? (tried saving to desktop, and into cloud drive too.. no dice...)
Any advice most welcome. Pretty annoying to waste time on such stuff...
  • Same thing here. I can still import data from September 20th, but nothing since - same message “… import file is not valid…”. I have compared later files with the file from 9/20 and there are the same number of fields, in exactly the same sequence, in exactly the same format. I have attempted to contact Mr. Overmars three times without success. I’m guessing he’s lost interest in the program, which is a darn shame because the functionality is amazing. Keeping my fingers crossed…

  • I understand your frustration. To resolve this issue, ensure that you are exporting the .csv file correctly from the Garmin App. Double-check that you're following the correct export steps and that the file is not corrupted. Additionally, make sure your Golf Shot Analytics app is up-to-date. If the problem persists, reach out to both Garmin and Golf Shot Analytics support for further assistance. Patience and persistence are key in troubleshooting technical issues like this.

  • Hey Mark (I assume) - Thanks for responding. I will reach out to Garmin support but I doubt they’ll be much interested since I can open their CSV file in Preview, Numbers and Google Sheets. I imported both the 9/20 file (which GSA still processes okay) as well as a current CSV file that does not import into GSA and they appear identical in terms of number of fields, field names, sequence and format. I’m exporting from the Garmin App the same way as always, Save to Files (iCloud) from an iPhone Xs. There is no apparent corruption of the files. Garmin App is 2.14.1 which was an update “3 weeks ago” which makes it September 13, well before I started having the error (sometime after 9/20). GSA says I have the most recent version, 2.20. I have sent multiple emails to GSA without any response. I would send you the files in question but I’m beginning to think this is not Mark but someone at Garmin. True? Thanks anyway. The R10 is AMAZING although today it did something I hadn’t seen before - a video was just the last half of my swing and me walking around afterwards. PS - thanks for the link to the golf cart problems, but I needed that five years ago when I was working the bag drop and cleaning carts. I’m retired now, and glad of it!

  • FYI

    Just tried to import a session, no issues.

    Know it will not help You, but at least it should not be a general issue after updates etc.

  • I think I found the problem. Sometime after 9/20 Garmin Golf iOS began putting extraneous characters in the date time stamp field between the time and the AM/PM. Curiously this does not cause a problem for Apple Preview or Numbers, or Google Sheets. If I re-export from Google Sheets the extraneous characters go away and GSA process the file successfully. I’ve posted in the Garmin Golf iOS forum and am waiting for a response. I’m guessing you are not using an iPhone, correct?

  • Sorry for not being very responsive for a while. I was very busy with other things. I now uploaded a new version 2.22 of GolfShotAnalytics that should solve the problem. As KCGolferGuy pointed out Garmin indeed added some weird non-printable character before the PM/AM indication. Clear a bug from their side. But it does not show up in spreadsheet programs. But GSA assumed there was a space there, so it could not parse the time anymore, leading to a problem. It should be solved not. Just install the new version.


  • Thanks, Mark. Good thing you were able to fix GSA because Garmin seems unable to fix Garmin Golf iOS...