I can no longer import Courses from Connect

When I try to import Courses (from Connect into Explore Web version). I get "An Error Occurred". This worked previously, but now does not. Any thoughts? Also, around the same time, i'm noticing that my Instinct is no longer uploading my activities to Explore IOS... but I am still getting my activities properly in the Connect iOS app. 

  • minor update... I worked with Garmin Tech Support... it appears at this point that there is some problem with taking Activites recorded with my Instinct watch, and converting them to Courses. Apparently, according to them, if a brand new course is created without coming from an Activity, the Courses are still available in Explore to import. All of my Courses are created from existing activities. Also, on another note, there seems to be an issue with Explore accepting Activities from the Instinct... I haven't been able to get an Activity to show in Explore (web or iOS) since January 26th. They have made a ticket for it... if i hear back i'll post it here.

  • Hi, I'm experiencing the same. Just get "an error occured". (I tested it again just now.) 

  • Hi - I have the same issue.  I can't really see why they have 2 different apps Explore and Connect - if I'd known about the difficulty in managing routes/courses/tracks/whatever you call it I would definitely have thought twice about buying an Instinct !!