Mini 2 sometimes has the Bluetooth insignia in the middle of the blue arrow.

My Mini 2 sometimes has the Bluetooth insignia in the middle of the blue arrow that shows my position. Is this indicating that Bluetooth has lost connection?

  • Hello, I am going to be moving this post to the explore app section as it applies to the app function and not the device directly. However, the following links explain what you are seeing. Blank Map, Incorrect Location, or No Location in the Garmin Explore App // Using Current Activity on the Garmin Explore App

  • This shows the device is providing GPS info via Bluetooth. The other option is to have the phone's GPS provide data.  Click on the Map Settings icon (upper left of Map page) and toggle with the Prefer Device Location switch.

  • Ok thanks, it is actually android not iOS if it matters. You answered my question there. Another question is why in the middle of a run does the Bluetooth indicator appear and disappear randomly, mostly being absent rather than present, with the phone never being more than a few feet from the GPS? Thanks 

  • Thank you! So if Prefer Device Location is on, it will use my Mini 2 and if off it use phone? Or it uses a combination of the two?

  • Yes, if the PDL is on the app will use the Mini 2's GPS, and if off, the app will use your phone's GPS. It should do this consistently, so if the Bluetooth indicator is randomly disappearing when the PDL is on, that suggests a problem.

    I had a different but similar problem, and I deleted and re-installed the app.  That solved the problem for me. You might want to try that.

  • Hello guys. My above post about appear/disappear needs some clarifying. What seems to happen is this. At first Bluetooth is connected as it does say it is on my phone, and I can sync no problem, but yet the BT insignia is not displayed in blue arrow, and it is not right now sitting here.

    I start hike, turn on tracking either by phone or Mini2. At some point in some hikes, the track line behind me will stop, the BT insignia will come on. If I turn BT in the phone off, the track line will display properly and be caught up to me as normal. If I then turn BT in the phone back on, the display track behind me will go back to the point the BT sign came on, and the BT insignia will be on again.

    Above test done with PDL on.

    Full treeless view of the sky with full service on cell phone at all points of the hike. Mini 2 on pack shoulder strap, phone on sternum strap 12 inches apart.

    I have not tried uninstall/reinstall just yet.

    Thanks guys, appreciate it.

  • HA! I went and tested the app with my 66i, and though it worked fine previously, I can't get the Bluetooth symbol to show up in the blue triangle. I've tried forgetting my phone (on 66i) and 66i (on phone), and deleting and re-installing the app. Turning both devices off and then on, etc.

    I tried toggling the PDL switch.

    I don't have an answer at this point.

  • I mis-spoke earlier, I had to do a complete reboot of my 66i to get the PDL to work. This erased all my preferences and I had to do a long re-synch. It worked fine after doing that.

    So now, it's not working again, but it's not worth it for me to do a complete reboot, especially if it's something I have to do over and over.

    You'll have to decide if it makes sense for you.

  • Thanks for your effort, appreciated. I probably would not go to the effort to do what you describe above every time but may do it for a test just to see. It is not critical that I use the phone rather than the device for display on the extended multiday hikes that I do. The Mini 2 is for communication, MapShare and SOS. I will still use my eTrex SE for navigation. But it is fun to play with the Explore app on short hikes. I think I am going to test by turning off the phones GPS and see what happens.

  • Yes, you should test and play around. When I got the PDL to work correctly by rebooting my device, I then had to reactivate inReach and re-customize my menus and settings. Since I have a lot of stored data, I also had to do a long synch. I knew what I was getting into, but I wanted to see if a reboot solved the problem and it did.

    The PDL switch is actually fairly recent, it wasn't on there when the Explore app was first released. I lived without it then, I can live without it today.