Sync fail

I can’t get my Instinct to sync with Garmin Explore on an iPad. It’s never worked. Garmin Connect works fine though. When it attempts to sync it connects and the wheel spins for a while before reporting “sync failed”.
I really don’t want to risk a factory reset, it’s taken ages to get the watch set up and I don’t want to risk the restore screwing up. I’ve tried deleting all activities, waypoints / locations, and courses from the watch. I’ve similarly tried deleting everything stored in Explore. I’ve switched everything off and on against of course, deleted the watch from Explore and repaired / reconnected, reinstalled Explore, used a different Apple device.
Garmin Explore 2.2, iOS 14.4.2, Instinct s/w version 14.20
The last entry in the diagnostic doesn’t look healthy, but it might not be significant:

2021/05/24 08:14:44:828 [com.garmin.gfdi][MessageReader] Received Protobuf Request (5043) request
2021/05/24 08:14:44:829 [com.garmin.gfdi][Protobuf] Failed to decode: invalidUTF8
2021/05/24 08:14:44:829 [com.garmin.gfdi][Protobuf] invalidResponse("Receive protobuf failed: parseError")

Any suggestions please?