gpsmap 64s support

Is the explore app going to be supported wit the gpsmap64s Just boight the model and found that the model is not supported at the moment.