Garmin web connect - activities not visible: IE, Edge & Chrome !!!

Since a week or more, I'm not able to see & edit the activities in the web page at all. the page is processing cojntinously in IE, Edge & Chrome.

Please assist ! thx

  • Are the activities missing in the list of all activities, or is just the data of a specific activity not loading on the concerned activity page? New activities only, or old ones too? Did you try accessing the data from another PC, preferably on another network? It could be a routing problem to some of Garmin's sub-domains, or due to an outdated DNS record for one of them.

  • I can see almost anything but the details of any activity. But everything is loading very slow ... and those activity détails (all) are not visible at all !

  • I can see almost anything but the details of any activity.

    It still not clear to me what you mean, a screenshot might help understanding it better. However, if you tell it loads very slow, then there either some local network problem, or a problem with the computer or with the router. Garmin's servers seem to work just fine, and there are no problems reported on the Status page either. As I wrote, try it from another computer, and preferably also from another network.

  • Here is the issue ... neverending loading for distinct activities,

    same thing ... maybe occasionally display all activities !

     the only place I see them, but can't edit etc ... is in News

  • Try temporarily disabling all plugins, especially diverse adblockers, also test it with a disabled anti-virus and firewall. If you find it comes from there, set up exceptions for Garmin domains. And as I wrote, test it from another network, and/or from another computer.

  • ... you could also consider closing all those ~100 tabs you seem to have open in your browser, and testing whether it gets quicker with just a single active tab (or just a couple of them).

  • I have the same issue, the "activities" page, or any specific activity page hangs forever. I tried with Brave (Chromium based), Chromium, and Firefox with the same result.

    The browser console indicates this error:

    Uncaught TypeError: Cannot read properties of undefined (reading 'split')
        at parseData (backbone-lib.js?bust=4.57.2.0:1:195788)
        at Object.success (backbone-lib.js?bust=4.57.2.0:1:195631)
        at o (backbone-lib.js?bust=4.57.2.0:1:128293)
        at Object.fireWith [as resolveWith] (backbone-lib.js?bust=4.57.2.0:1:129091)
        at S (backbone-lib.js?bust=4.57.2.0:1:181435)
        at XMLHttpRequest.t (backbone-lib.js?bust=4.57.2.0:1:184849)

    As well as the following warning:

    DevTools failed to load source map: Could not load content for https://connect.garmin.com/web-react/static/js/261.eb816a1b.chunk.js.map: HTTP error: status code 403, net::ERR_HTTP_RESPONSE_CODE_FAILURE

    Although it may be a coincidence, this started happening right after I imported a tour (via GPX).
    I tested the Android app, and all works fine there, so it's really an issue with the web application, and not some corrupted activity that could make the JS crash for some reason.

  • Thx Trux, ... although your point doesn't seems to be enough relevant for me, because the same behaviour it's replicated in IE and Chrome, for which I don't have any other tabs opened.

    PS. Wanderer seems to have the same incident.

  • Did you already try using accessing the website from another network and from a different computer, as I suggested?

  • ... and, BTW, do you have the same delays when opening an activity of someone else? For example an activity of a Connection of yours, or a public activity. And also please post a link to one of your activities, so that we can check whether we'll see the problem too. You'll have to make it public, though (use the GC Mobile app, if it cannot be done in GC Web)