This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Adding a weigh in, it's giving different weights in stone

So today I added a weigh in as 11 stone 10 pounds. Yet after clicking ok it's showing as 12 stone 10 pounds.

The bmi is the same as my usual 11 stone 10 pounds. 

Is this happening to anyone else? 

Why is it showing a stone more than what I am entering?

  • If you manually add a weight with connect Web, it still adds a stone when viewing the entry on the app.

    But weight displays correctly on the web or is it displayed incorrectly in both locations? The app should get its data from the web.

    I'm asking, because I see the direction to email the android devs earlier in this thread. The recommendation has always been for anyone with a Garmin issue to open a case using the Garmin Customer Support site, which should get the case routed appropriately. It shouldn't be up to the customer to decide which support group should fix it. Otherwise, there is the potential to delay the resolution.

    Also, tagging here  & 

  • This started for me just over a week ago. I noticed when inputting weight if you were trying to add a even number of stones it worked, but on an odd number like 11 stone, it would show up as 12 after adding it (tried it with 13 stone and it changed to 14). It has also increased all my back dated weights by 1 stone too. Then Thursday and Friday (24th/25th Aug 2023) this week it started working again for the odd numbers, so I thought the input was fixed, although backdated weights were still wrong. Then Saturday it's back to inputting wrong again, but now instead of only effecting odd number stones it is just adding 1 stone on to any weight you put in. The strange thing is the weight graph is still showing the weight as being correct, so I don't want to try to manually correct it by putting in 1 stone less as this will make the graph wrong and when it does eventually get fixed we'll probably have to change it all back manually too. It's really annoying when I just spent weeks losing a stone and now I'm looking at the same numbers again; even though I know it is wrong it is still demoralising :(

  • 5407156 I think you are right.

    My weights this week every day up to Wednesday were 11, 7 or higher, and inputted as 12, 7 or higher, but on Thursday and Friday I was 11, 6 and 11, 5.5 and they inputted corrtly. Looking at my backdated weights that are wrong most of them are over 7 pounds, so display wrong, but the odd one that is right is under 7 pounds of a stone 

  • Hi Katy, is this because your husband is in the lower half of a stone e.g. from 13st 0 to 13st 6.5 and you are in the upper half of a stone e.g. 11st 7 to 11st 14? 

    I think user 5407156 is right and that it is a rounding error. All my recent and historical weight inputs of 11st 7 to 11st 13.5 have increased by 1 stone, but when I put in 11st 5.5 and 11st 6 on Thursday and Friday this week it inputted correctly. 

  • It definitely is a rounding error. I've already got a support case open with Garmin about this and have emailed them a video screenshot clearly showing them their error by using my weight goal:!Amd4PcaateumgaBAq-xuG7Q3U8ENmA

  • Yes, he is in the lower half whereas I'm in the upper half. He's just tested it by entering a lower weight and it added the stone. He said that when he entered above 7lb on the stone it added the extra stone and anything below it was right. How odd!

  • Mine is not a rounding error. 

    It doesn't matter how many pounds I enter at all, the number for stones increases by exactly one whole stone no matter what.

    So mine is not affected by rounding. 

  • I've had this response from Garmin today 

    Thank you for contacting Garmin Support. This is a known issue, we do have a fix pending that will be implemented in an upcoming update to resolve it. This will apply to your past entries as well, I apologize for the inconvenience. 

  • I noticed an update available for Garmin Connect in the Google Play Store this morning. I've installed it hoping that it would fix the extra stone issue in the weight section.  

    I'm now on v4.70.1 so it has changed from the v4.70 HOWEVER, the issue persists. I've cleared the apps cache and restarted my phone too.  Pensive 

  • My newest daily Add Weight entry in the app is appearing accurately and exactly at the weight that I input it this morning.

    However, in the app, all the historic weight entries going back exactly one year, all still remain one stone higher than they should be.

    So, any new entries are 100% perfect. But all historic entries are one stone heavier still. The issue is halfway resolved then!