Livetracking starts but doesn't update or transmit location on new Pixel 5

I have long been a user of the Livetracking feature and have it paired with Strava Beacon. When I start a run, it automatically starts the livetracking and I get a notification that the livetracking has started, I also see that Strava Beacon gets sent out. However, Garmin connect never actually sends any location data so my wife can't track me. In Strava it says the user hasn't started the activity, in Garmin it shows a map and says no location data sent.

Garmin Connect has all permissions (location, sms, phone, etc.), the battery is not optimized (can run in the background), and it has background data permissions. I've gone over every setting for livetracking inside of Garmin Connect and it is all set to do what is needed.

As it's dark, cold, and icy, my wife would really feel better with my running if she could track my progress.

  • A frequent problem with LiveTrack is, that you start it near your home, where your phone is still connected to your home WiFi. When you start moving, it loses the connection to the WiFi router, and before the phone switches to the mobile data, it takes a while, and in the mean time the Live Track session is interrupted because of the connection loss. The solution: disabling the WiFi on your phone, before you start your activity.

    Not sure whether it is your case, but it is definitely worth of trying.

  • Thank you for the suggestion. It made a lot of sense so I tried it last night. Unfortunately I still had the same results. The thing that's odd to me is that I can start an activity and see that the Garmin Beacon gets sent. When I open the beacon link it shows the map but up near the top it says "No location data" to me that implies that the watch (Forerunner 645) is not syncing location properly with the phone to transmit that data. 

    I've checked that the Connect app has all the relevant permissions, including background use for both data and location, so it should have the ability to do so.

  • including background use for both data and location

    Location comes from the watch, not from the phone. Make sure the GPS is locked before you start the activity, and that the Bluetooth connection between the watch and the phone is functional.

  • Yes, I understand that the location comes from the watch. The location is locked before I start and there is a bluetooth connection between the watch and the phone. But it still does not transmit my location.

  • Make sure you have the latest Garmin Connect app version (4.37.2 at the momnet). Check out you privacy settings, and the privacy zone - if it is too large, the session may time out before you leave the zone. Try starting the LiveTrack session manually, instead of using the automatic start, just to see whether it makes any difference. If nothing heps, contact the Customer Support, and let them investigate it.

  • I’m having this same issue. When I manually start livetrack it provides data. When I use auto start it sends the notifications- the Garmin notification when opened states “no location data”, the Strava status states “activity not started”. 
    I have a fenix 5x plus, software version is 14.00 (e036468). Garmin connect app software version 4.41.2.1. 
    iPhone location services set to “on” and connect permissions set to “always” with precise location authorized. Connect privacy set to groups and my connections for all settings. Haven’t opted out or revoked permission for any of the data categories. 
    After confirming all these settings for Garmin customer support, at the advice of Garmin techs I disconnected my watch from my phone “forget”, uninstalled connect, restarted my phone and watch, reinstalled connect, rechecked (or granted permission again where necessary), restarted my phone and watch again. Did another test with auto start and it’s still not working. 
    to be clear this function use to work - we think it stopped a few months ago. I am never on WiFi when I start my runs, I wait for gps to connect before starting, I run with my phone and leave the connect app open. Any thoughts?

  • Any thoughts?

    Well, it looks like you are on an iPhone, although you are posting to the Android forum. If you were using Android, I'd suggest trying to install an older version from an APK archive - it often helps users with similar problems (for example here), since there seems to be a recoccuring bug, changing the auto-start behaviour with certain Garmin models at every release of the GC Mobile app. However, I do not know whether you have such possibility with an iPhone - you best ask on the iOS forum.

  • Ha! Totally didn’t see that, just googling the issue and saw the post. Appreciate you steering me in the right direction, and will search an iOS forum

  • Are you still having this problem? I am, and I've tried everything except reverting back to an old version of Connect, which seems like a bad option to me.

  • It was a watch issue for me. I had to replace the watch for it to work again. But now it works perfectly again.