This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Fenix 5x plus not connecting to galaxy s10 after sw update

I was recently forced to update my galaxy s10 to the newest sw and since then haven't been able to reconnect my fenix 5x plus . I have an older phone that it will still connect to and currently have o it connected to my work phone . I tried removing device from the plane and I also reset watch to factory settings.
Anyone else having similar issues?

  • 1) First of all check out whether the latest version of software (firmware) is installed on your watch. If you can sucessfully connect to the watch with Garmin Express via the USB cable, check for the watch software update with it. Otherwise, look up the watch software version directly on the device (typically long-press the menu button » Settings » About, but it may depend on the watch model), and verify with the support page for your model on Garmin's website whether there is an update available.

    2) You should also try turning off completely both your phone and the watch, waiting a moment, and then turning them back on again. Make sure Bluetooth is on, on both sides.

    3) When you go to the Bluetooth details on the phone (swipe down the top and long-tap the BT symbol), is your watch visible? If not, tap Scan up right. If yes, then in wich section? Available or Paired? If it is in the Available section, follow the installation instructions from you user manual and pair the devices.

    4) Try disconnecting all other BT active devices, such as headphones, etc.

    5) Check the menu on the BT screen, check the Advanced option and verfiy all parameters. On some phones there is an option for clearing the Bluetooth cache. If you find it, use it. If you don't, google it up for your phone model.

    6) Try removing the pairing of the watch from phone's BT devices, and re-pairing it from the phone's BT page (unlike what Garmin's User Manual suggests). If it does not help, remove the pairing again and try initializing the pairing from the watch, just like the User Manual tells.

    7) Verify all application permissions in Android Settings » Apps » Connect » Permissions. Check also other sections of the application page in the system settings. The manufacturer may have added aditional parameters. Check all for any suspectible limitations.

    8) The Permissions are also accessible from Garmin Connect menu » Settings » Phone Permissions, they should be all turned on

    9) In the Privacy Settings of your Garmin Connect Web, make sure the options Storage & Processing and Device Upload are enabled

    10) Try some troubleshooting guides from Garmin Support:

    11) Check the following troubleshooting guide for Huawei, it may apply to your phone perhaps too:

    12) Another tip for Huawei, although for notifications, may perhaps help for certain phones and syncing too:

    13) And yet more tips for Huawei owners:

    14) On some phones (namely reported on several Samsung models), you may need to reset the network settings, typically under Settings » General management » Reset » Reset network settingsPlease note you'll loose all network settings for wi-fi and bluetooth. (source)

    15) App Overlays may pose a problem on some models of phones, as reported in this thread. Read the thread if you do not know what App Overlays are, or when you want to learn how to disable them.

    16) Check the changelog of the last OS update of your phone, or contact their support to find out which of the changes of their software could have led to this outcome.

    17) If nothing helps and you know the previous version of Garmin Connect Mobile worked all right, consider instaling an older version  from an APK archive. There are several inofficial APK archives available on the web (for example here). Use on own risk - there is no guarantee from Google or from Garmin that those files were not modified by a 3rd party (though I have only positive experience with the mentioned website)  

  • Thanks for the help. fyi -I ended up pairing through bluetooth devices on my phone as opposed to how I have always paired it before which is through app. 

    I guess there's more than one way to skin a chicken

  • I was having the same issue after the update to Garmin Connect Mobile 4.27 (with vivoactive 3 and phone Moto E2).

    Thanks 4531762 for the hint, this did the trick for me too. After pairing the watch via the phone's bluetooth menu it now works reliably for me too. Like you I previously had always paired it in the app only (which I believe was also what Garmin had recommended?).

  • Thanks.  Ended up removing everything and repairing and resyncing and it finally worked!