This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Earthmate for Android

I can log in to the Garmin website and forums, but when I try to log in from within Earthmate I get an Authentication error invalid password. Using Android 9 on Samsung Galaxy S9+.

Tried uninstalling/ reinstalling as well as new password on the website- still get the error in the app

Anyone come across this before?

Cheers,

Rob

Parents
  • I'm having the same behavior, also on an Android.   I created my account on the Garmin site today and was able to log into the website successfully, however when I try to log into the app I keep getting "Authentication Error; Incorrect username [OK]".  This is despite using the same information on both website and app.

    I've also reset my password on the website and verified the change by logging into it from different browsers with no issue when using the new credentials.

    Does anyone know if there is an expected delay from when an account is created on the site to when it is reachable by the app?

    Thanks!

Reply
  • I'm having the same behavior, also on an Android.   I created my account on the Garmin site today and was able to log into the website successfully, however when I try to log into the app I keep getting "Authentication Error; Incorrect username [OK]".  This is despite using the same information on both website and app.

    I've also reset my password on the website and verified the change by logging into it from different browsers with no issue when using the new credentials.

    Does anyone know if there is an expected delay from when an account is created on the site to when it is reachable by the app?

    Thanks!

Children