This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

watchface save settings button not working

I have Garmin connect IQ app v2.14 on Android 8 Oreo

watchface parameters save settings button not working anymore.

I tried to reinstall connect IQ app but wih no luck .

Apparently not everybody seems concerned ...

Is someone with Garmin connect IQ app v2.14 on Android 8 Oreo not experiencing the same thing ?

(I try to identify whether it's android version or app version, or something else that causes the problem)

  • I've got IQ v2.14 and Android 11 and I can access to the Watchfaces settings

  • Thanks for the feedback 

  • Can you save the settings you've changed?

  • If I understood correctly, I go to third party watchface, settings, change a parameter and then click on save button. The new settings are saved correctly for me.

    Provide with the steps if the above is not correct.


  • When I click the save button, nothing happens. So I have to click the back button and the app asks me, if I want to exit without saving the changes.

  • Plugged my watch to the PC to change a color of my watchface with Express, then the watchface was broken. Some settings were not possible, I can't make icons appear again etc. The whole Garmin software is crap!

  • Hi Carmen, 

    Try this. First thing to do is a reset of your watch. Press and hold light button until your watch turn off. Turn it on. Then, make sure your mobile apps are up to date. Then, try with the watchface settings again. 

    Is this happening with one watch face or all? Do you have this problem with the stock watchface?

    Sometimes is not garmin and the watchface can have a problem. In that case, you need to contact the developer. 

    Otherwise, contact support. They may give you a better resolution. 

  • I already tried that. I can access the settings of all my watchfaces, but I can't save the changes. In Express I can save, but some settings can't be changed (what they can be in Connect Mobile oder Connect IQ) and one watchface broke. My FR735 has only one stock watchface and that can't be modified. Obviously the whole software and the system behind it is broken.

  • I guess It seems to be a connectivity problem between connect and watch due to the watch software. I would contact support. Have you got installed the latest software v9.70? 

    Sorry I cannot help you more as I own a Fenix 7. If it is in warranty they can replace the watch, otherwise, they may offer an alternative depend on how old is your watch.

    All the best Carmen!

  • My FR735XT has the latest software. I guess that the app or the system behind is broken. I can sync my watch, I receive notifications, I can install new watchfaces. But I can't save the changes I made in them because the ready or save button just shows a gray dot that it was pressed but nothing happens. So I go back without saving changes.