This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin Express error: The SD card cannot be larger than 32 GB with a 32GB SD card (3 of them)

I'm trying to update the software and add my maps to my new Echomap UHD 72sv.

I've been at it for about 8 hours now and am getting nowhere.

Attempting to update the software and maps via mobile either crashes the display, errors out, or it just turns off after an hour of it working on the transfer and trying to validate.

So I tried to go the route of Garmin express and load the software update to an SD card, update the plotter, then load the maps to SD card and install them.

Another hour later. I have tried 3 different MicroSD HC cards that are 32GB each. 2 are class 10 and 1 is U1. all 3 recognize fine in windows and I formatted them FAT32.

All three cards Garmin express gives an error when trying to load the Software update to the SD card "The SD card cannot be larger than 32 GB". All 3 of the SD cards are 32GB and all of them say this error.

This whole ecosystem is so unbelievably buggy.

Haven't found any other topics on the forum in the search or on google of this error for anyone else.

Latest Garmin Express installed just today.

  • Update on this.

    The 2 class 10 cards have a size in windows of 31.2GB. it says it is larger than 32GB

    The u1 card has a size capacity in windows of 29.9GB. it says it is larger than 32GB

    A FOURTH card I took out of my go pro has a size capacity in windows of 29.7GB. Garmin Express accepts it.

    For al the people who find this in the future... if your using a '32GB' card and windows sees it as larger than 29.7GB of usable space, it is probably why Garmin Express won't accept it.

    Try some other cards. The one that worked for me is a SanDisk brand class 10.

    Let's see what bug I run into next. Worst user experience I've ever had in 30 years of dealing with tech devices.

  • I had a similar problem several years ago with a camera.  Numerous attempts to format the card within Windows failed and the camera kept saying it was more than the actual card size.  I used the SD Association formatting tool and reformatted the card and the problem was eliminated.  I won't say the brand of the card but it was a well known brand.

    The SD Association formatting tool is at SD Association formatting tool should you want to try it.

  • Just a point of interest; in the release notes for Garmin Express v7.17.1 (just recently released) one of the changes reads as follows.

    • Fixed an issue with certain devices not being able to perform a map update on a SD card.

    Perhaps an update to GE is in order.

  • I'm having the same issue, card I'm using says it's 30.2GB.  I tried the The SD Association formatting tool that another user had suggested with no luck.  Lastly, I'm using the latest version of GE  

  • Give this a try.  Go into the normal Windows formatting tool and access the card.  Change the "Allocation unit size" to 32 kilobytes.  Then uncheck the "Quick Format" option and hit the "Start" button.  The first time you format with the Quick Format option disabled might take a few minutes.  This will reset the allocation unit size to 32 KB and the card will have a capacity of about 29.7 GB.  Retest and report back.

  • Thanks for the suggestion.  I tried that and it formatted to 30.2 again.  

  • I got it work by changing the partition to 29.75 using Mini Tool Partition Wizard that I use for back-ups.  It's installing now, hopefully that it for the issues. Thanks for your help!

  • All this formatting is being done to FAT32, correct?

  • Same issue with a Mac after updating to GE  The SD cards worked fine last year but do not with the current GE update.  GE is also crashing frequently.