New Fenix 6s pro - During set-up it won't allow me to install TopoActive 2018.20

Hello All,

Just got my first Garmin and I have set it up but there remains one update still to be installed - TopoActive Europe 2018.20 which will not install.

I have no idea why as no details come up with the error message just the below. 

I have seen loads of comments about issues but they all appears to be for a different version than the one that it tells me to install. I have no other options for another version. 

Any help would be greatly appreciated.