eTrex 30x Blue Pin on Route

Hi All,

I have searched high and low on how to solve this problem. There are notable folks who have responded to this exact issue multiple times on these forums, and I assure you I've already read their replies and tried what they suggest. Most of the advice given was for around 5-9 years ago. Whatever I'm doing now, is not working.

I made a route in Base Camp (267 points, if that matters. I hear of a max of 250, but 267 works fine on my end), saved as GPX, uploaded to my eTrex 30x (brand new as of last week) and am shocked at the blue pins all over the screen. Here's what I've tried to have them removed:

Created a 32x32 magenta (255, 0, 255) BMP (24 bit) and PNG name "Pin, Blue.bmp" or .png respectively, and uploaded to my gps' directory GARMIN/CustomSymbols. No worky. Please understand I don't care about them displaying in BaseCamp, so I'm not worried about "000.bmp" to affect BaseCamp. I need these blue pins off of the damn gps screen.

Tried it at 24x24, bmp, png, capitalized file name, not capitalized. It seems no matter what I do, the blue pins remain on the damn route. I'm pulling my hair out on this one, or what little hair I have left.

Anyone have any diagnostics I can try? As tech savvy as I think I am, this one is throwing me for a loop. Thanks anyone for any pointers!

EDIT EDIT: Alright, the magical key to this entire saga (spanning multiple days) is to use a windows computer to create the custom symbol. I have been using my main pc (Ubuntu Linux) to create the 24 bit bmp, but nothing worked. I finally tried a friend's windows machine (Paint) and it worked first time. Something about how my Unix system is formatting the image is causing it not to display correctly on the gps. I know this is a windows forum, but Garmin doesn't support Linux (Why?) so I don't care. Leaving this for the next poor soul that gets sucked into Garmin's *** and uses Linux. Good day.

Parents Reply Children
No Data