Notifications not working on FR945 from Xiaomi Mi 9 - Solved

I'm posting this simply because it may help someone else - I was bashing my head against a brick wall, trying everything until I finally figured it out (for me at least).

Problem:

Notifications not working on FR945 from Xiaomi Mi 9. Incoming call alert works, but I don't get any smart notifications. I've tried pretty much everything to do with permissions and can't get anything. I recently changed from an LG G6 which worked fine. Anyone else have this issue?

Solution:

On phone goto [settings > additional settings > privacy > special app access > notification access] and toggle the switch for Garmin Connect (Smart Notifications) off and on again (or move to on, if in the off position). I had previously checked this a number of times, but because it was already in the ON position, I simply left it and moved on. The solution was to toggle the switch OFF and ON again - such a simple thing that solved a thing that had been doing my nut for ages!

Here are some other things to try:

- Make sure Garmin Connect is in your autostart items

- goto settings "Battery Optimisation" and make sure that Garmin Connect and the apps you want notifications from are not optimised

- Uninstall and re-install Garmin Connect and any apps that are not giving you notifications

- Make sure that both Android and Miui are on the latest update

Hope this helps someone.

Top Replies

All Replies