Vivosmart 4 isn't tracking data or sending to connect even tho it says it syncing.

I had a old vivosmart 4 that worked till yesterday. It had gotten old and battery not working that good so I ordered a new one. I removed the old one, set up the new one. But the new one isn't tracking steps or anything. According to connect it says it syncing. No steps is shown on the device either. 

Setting it up and changing clock face works. It sends current pulse. But that's it. 

So I thought it was the new device so I removed the new one from connect.

Connected the old one but it has exactly the same issue now. 

Software 4.40 on both devices and the new garmin connect installed in the phone. Samsung galaxy s9. 

  • I have reinstalled the connect app.
  • Restarted the phone.
  • Reset and reinstalled vivosmart 4.
  • Tried a new connect account and setting it all upp again. (with a reset device) 
  • Tried with a new device (Samsung galaxy tab 5)

None of the devices sends more than just current pulse. No steps, sleep etc. Nothing that I do changes this.