Inaccurate Run Activity Distance

Product: Vivomove Style

SW: 4.00

TSC: 2.70

SNS: 7.00

NET: 2.00

I've had my watch for about a year and a half. I use it primarily to track running activities with GPS turned on.

For roughly the last two months, I've noticed the measured distance becoming wildly inaccurate. I've had ~5 mile runs be measured as ~8 miles and ~10 mile runs be measured as ~17 miles. The 1-mile "lap" notifications on the watch usually start off looking normal during the run before they grow more (incorrectly) frequent as it goes on.

I often run with the Runkeeper app active as well (as it provides helpful audio cues) and the GPS measurements there are accurate to self-measurements on Google maps.

Any guidance would be appreciated!

  • The watch itself doesn’t have GPS but uses GPS from your phone (it’s called connected GPS).

    Could be something strange going on with your phone.

  • Right, I'm aware it's using the phone GPS, but I feel confident from the Runkeeper data that the phone GPS is not misbehaving. (I guess it's fair to say Runkeeper could just have better handling of bad data, but I've got no way to confirm/deny that.)

    For what it's worth, my runs are generally performed in well-developed urban areas where I've never had trouble getting a GPS signal (on any device), so I could probably rule out any signal issues.

    There are several recent posts showing up in the "related" panel that seem to describe simalar observations too.

    I haven't tried this yet, but I'm considering performing a factory reset to see if that has any impact.