This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Scale won't complete setup (Wrench Icon)

I've had the scale for about 12 months or so now and its generally been... ok... (quibbles about not connecting to MFP aside).


In the past few weeks it seemed to loose my settings and register me as my wife.

I then removed the device from the garmin connect app and reset everything up.

Now it gets stuck on a 'wrench' icon. I've deleted our user details a number of times and re-added. I also get an 'X' in the top right of the display.

The wi-fi setup seems to complete ok so not sure what gives.

Any thoughts?
  • Thanks it working on dd-wrt. Garmin Index Scale is working now correctly!

  • Like several others here, a working scale began to fail to get new measurements to the cloud-based Connect server.  Still useable but I needed to record measurements by hand.    Thought to try factory reset, and ended up with a scale that would (even after removing and returning batteries and pressing the setup button for the recommended 5 seconds) come up with the WiFi symbol blinking, start with some odd shape for about 5 seconds and then transition to the blinking wrench which never goes away.

    I read the many comments about networking here, but am not about to lower the security guards on my router just to make the scale work.   I have a cell modem for travel, and I thought if I could but get to the original setup state with the bluetooth and ANT symbols I could restart with my cellphone through bluetooth and configure the scale to use the cell modem's network.   But I couldn't get to that starting state.   I was (still am actually) thinking ugly thoughts about Garmin's bad design for a factory reset that isn't.

    But then a miracle occurred.   While the wrench was blinking I held the reset button in for a long long long time, maybe a couple of minutes.  Was out of options.  But then the miracle occurred,.  The device shifted into the original startup state with the bluetooth symbol.  From there I could re-initialize using the Connect app on my phone, connect it to the cell modem's network, and after all this, was back to expected behavior, so long as I turn my cell modem on first to be available for the scale to connect to when it wakes up.  

    Hope this helps _someone_ get back to the true factor reset state after which one has options.

  • Hey, prof Hammock,

    did this happen recently?  My scale fell off the network after working fine for a year.  it was still working as a scale but not connecting to wifi.  I reset the scale to try to reconnect and now it won't connect and won't weigh either.  As usual with garmin there are no support docs on any issues.  I'm going to try your very long press reset method.  

  • Im having the same issue. Just purchases the Garmin Index  S2 Smart Scale and it wont let me add device.  Contacted customer service and they couldn't help me.  Told me i had to mail it back to them at my own expense.  SO basically Garmin is selling expensive paper weights and they know it. 

  • This happened in October 2020 sometime.  I think it was correlated with an automatic update to my home mesh network (eero).  Even if it stops getting internet connection off my cell modem I’m not touching reset again!  Otherwise, so long as I stay on the scale a little while it finds the cell modem’s network and pushes the measurements out to the Connect server.

    Hope the ‘long push’ of the reset button works for you.  Very very frustrating to not have the device go the factory reset state when following the instructions.

  • I recently had a similar problem that happened after I tried to set up the scale at my new place.   I couldn’t get the Garmin Index Scale to connect to my wifi router, although everything appeared to connect fine during the setup. 

    after several hours of frustration in which I had tried several times to set up the device, I determined that it was having trouble connecting to my Eero WiFi network.  So I set up a different network using an older WiFi router that I had laying around, and it works perfectly now.  

    I am hoping to figure out what the problem is with connecting to the Eero router, since it seems ridiculous to have to maintain an entire WiFi network just so that I can use my scale!  

    if anyone else figures it out or has any ideas, would love to hear about them!!

  • This problem also happened to me with Eero in October.  I eventually did the change of DNS to and which worked.  After the scale registered, I returned my Eero DNS to default setting.  Of course the scale could not find the wifi now so I just went to scale setup, with no issue now, and connected to my original default network and everything now works fine using Eero default DNS, not the Google DNS once again.

  • Ok adopting scale on another device worked for me. Thinking reason my wifi broke was scale only likes channel width 40. I changed it to 80 and 160 that’s when it broke. Reconnecting on my primary device failed after repeat attempts. I would try removing app and signing in again too. Happy exercise