This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

130 Device won't charge, flashing display screen disconnects other items connected to my computer

I've had my Edge 130 since May and everything worked fine until recently.


1) my 130 won't charge and does not register in my file explorer (Windows 10)

2) 130 won't turn on -  flashing display only

3) my laptop computer has 2 additional display monitors connected. when I connect the 130 to my computer, both displays go blank as if they were not connected at all. (Actually, anything connected via USB to my computer is disconnected). The only way I cand get the screens running again is to unplug them and replug them with the 130 disconnected. 

I have tried everything I have read in the user manual, message boards, forums et.   Nothing works.  Same condition: flashing display, no ability to charge.... 

Is this Garmin Edge 130 broken after just 5 months? 

Thanks to anyone who responds with a knowledgable possible solution or a definitive answer as to whether the device is just broken.  

Garmin, any answers?