Fenix 5S Plus sudden increase in battery drain

My ~3yo Fenix 5S Plus suddenly started draining battery much quicker than before (100% to zero in 24h with no activity and all sensors off). I used to be able to go for a week without charging. I cannot tell what triggered the change, if anything at all. I have already tried (to no avail) all the possible factory reset procedures, including the one triggered by pressing all the 4 buttons. Now the watch is on factory settings, except that I disabled everything obvious that could drain battery (HR monitor, bluetooth, wifi, activity tracking).
The only possible remaining lead to an explanation is that in the "Debug" folder of the watch (which apparently survives factory resets), the file ERR_LOG.BAK contains an entry timestamped 7 Jan 2023 (see below) which may be exactly when the issue first appeared. This is the entry:

2900 (fenix 5S Plus) SW ver: 1800
Build Type: RELEASE
ESN: 3977555971
01/07/23 22:39:37
PWR RST CTRL: 0x00000082

Does anyone know how I can access someone able to read what this might mean? I'd love to know whether this may be a clue to the cause of my battery drain problem. Perhaps the watch is gone, but at least if I could tell what behavior or event triggered the problem, I can avoid it in the future. Thanks in advance!

  • Looks like it has been fixed? Yesterday i woke up with a power icon on the watch. Charged it and held the power button until it started up again, now it is draining as normal again.

    Nightly update maybe?

  • Update from my end about the Fenix 5S Plus from the initial post of this thread. Starting from the situation described in the beginning -- oldish watch, Garmin support not able to help further, battery drain too fast for the device to be of any use. A few days later, any screens with white theme also started to flicker so badly that it would be impossible to even see what was going on. At that point I decided that either I had a device ready to be recycled, or that I could try a few hacks to see if there was any way to salvage it. Here's what happened:

    1. I bought a battery off ebay (a used original battery for the same model, not the compatible ones that I wasn't sure about) and got a local watch repair shop to replace it. Battery drain problem persisted, and adding to that, now the device would just turn off frequently for no reason. My sense is that the replacement battery was bad, but I can't be sure. Either way, that plan didn't work.

    2. I had my local watch shop put the old battery back. Immediately after replacing it back, not only did the watch work - the battery drain went back to normal! I still had the display going mostly white when the screen theme was white, which I managed by replacing everywhere possible with black themes. I still couldn't see any maps, use white-only functions such as timer, navigating the systems setting was hit and miss, but still, the watch was kind of functioning. (I've been injured, so very little need to use it to record serious workouts).

    3. About a week later, a white round spot about 5mm wide appeared in the SE part of the screen, just by 5 o'clock. It is visible in any screens and feels like it's a physical damage to the pixels themselves. I was still happy enough with the limited functionality I had, and the spot didn't affect functioning at all. Battery duration was as good as had been before the initial malfunctioning.

    4. Last week, suddenly, the glitches in the white themes disappeared. So now I have a perfectly functioning Fenix 5S Plus, with good battery and all, only with a white 5mm dot at around 5 o'clock.

    I honestly don't know what to make of all of the above (nor how long it will last). In the beginning, everything suggested this had been caused by a software problem in the beginning, but then the rest of the story seems to potentially point to a battery issue. And the 5mm white dot - no idea. My takeaway is that when I eventually replace the watch, it will likely not be a Fenix, but a different model (still a Garmin because all in all, the brand remains best in the market for my type of uses). I've had functionality issues with Fenix'es twice already, and my sense is there's something that still needs to be improved in the resiliency of either hardware or software here.

    I'm writing all this simply to provide more datapoints to this thread. Good luck to everyone with a similar problem!

  • did you do a firmware update? I bought a new battery for mine, and whilst this did improve things marginally it was clear from this experiment that a software bug had been introduced that prematurely drained the battery and Garmin refused to acknowledge this issue. The actively tried to encourage me to part with £150 for a replacement battery.

    So can anyone else confirm this previous issue has now been resolved?

    Call me a skeptic but isn't this the sort of thing Apple is getting sued for? Writing code to impact older hardware to encourage upgrades?

  • Strange, checking the firmware V 25.00 is the current version which was updated in February 2022 so I'm not sure an update has fixed your issue...? What there anything else that you did?

  • You own a Fenix 5. Current software for your watch is v25.10. This Forum thread for the Fenix 5 Plus series - a Fenix 5 Plus series watch up to date is v19.10 software.

  • weird, my watch is on 25.00, says it's up to date (is also on auto update) and this link says 25.00 is the current version: www8.garmin.com/.../download_details.jsp

  • I did nothing myself. Woke up with the icon on my screen, charged it and started it again. Version 19.10 for fenix 5 plus. Battery is fine now, 10% down since yesterday with everything on except gps.

  • Yes. I didn't mention software because the fact that my device has regained battery functionality after I unmounted and remounted the same battery, does prove that the cause of the malfunctioning was not software. 

    In fact, I had only started playing with hardware after assessing that no software upgrade/downgrade that I could find online (both operating system and specific modules e.g. GPS module) would make any difference to the battery drain, which had led me to conclude (tentatively at the time) that I wasn't experiencing a software problem.

  • I have used the original battery and also a replacement non Garmin battery fully charged both and watch them decline from full charge to zero, swapped them about and repeated

    I have also removed apps and disabled heart rate from GC mobile app, no change 

    the fact that it is affecting so many people from around the world suggests that it is a software issue, it also affects other watch models but not all, do these all have the same battery in them, I doubt it, do they have the same gps chip,maybe

    i have checked the folders on the device and no extra files have been pushed on the fly

    maybe Garmin is killing off models with screws and easy access in favour of sealed units, so battery changes are harder to do

    majority of people with all rechargeable devices boil the batteries to death with constant unnecessary charging