GPS Ready always on

About a week ago, my Fenix 5 started having a problem. When I am recording an activity which could be bike or run, the “gps ready” alert comes on and covers one of the data fields and won’t go away during the entire activity. This watch is 2 months old and did not have this problem until last week. So I cannot see one of my fields during the entire race?  Anyone know how to fix this.  I have tried Turing it on and off. I have tried having 2 or 3 or 4 fields, and I can see all the fields for about 3 seconds when I start the activity, but then the notice comes up, covers a data field until I end the activity. 

  • Have you tried turning it off by pressing the light button for like > 10 seconds until it shuts off?

  • You probably would have noticed if it didn't - so I'm assuming the start button is working, no auto pause feature is active, and activities are saved OK. I hope Narziss' answer helped, but if not: did you install a new datafield or watch face lately? Did you update the watch with Garmin Express to install the latest software and maps? Do you have other sensors (external heart rate belt, foot pod, ..) active? Although it is not the exact same behavior, an external sensor with a low battery can disconnect/re-connect frequently, and cause that status row to pop up often.

  • Had the same issuesince the last time i connected it on my pc. Tried the on off solution asNarziss suggested and today went cycling and seems to be all good. Also the GPS looks like its working much better during my swimming sessions.