Fenix 5 Plus does not sees any Wifi networks

I have ongoing problem with my Fenix 5 Plus (firmware 6.0)- it does not sees any WiFi networks. It was working in the past, and primary use for me was to synchronize Spotify playlists.
Strangely - it does not connect to earlier defined network anyway. What is more - it does not sees ANY network - no matter if the search is done via watch itself or via Connect app (on Android). I tried many times in many places - so my home network, on on public networks, etc.
What is more, just today I have replaced my home Access Points, and I have set up entirely new WiFi network at home. It works perfectly fine with all home devices - but F5+ simply does not sees it.
The activities synchronizing works fine over Bluetooth, but my Spotify playlists have expired - so I cannot use them anymore.
Have anyone experienced such problem? Any advice's?
  • I had a similar issue recently. I wanted to sync my Spotify playlists but the watch refused to connect to any of the earlier setup WIFIs. Unlike, what you described, the WIFI search on the watch showed some WIFIs but not mine, which was 1m away from the watch. So I tried it with the Garmin Connect App on my phone, but also no success. Finally, I used my Laptop and the Garmin Express application to add a new WIFI, and then the watch actually connected to it.... So maybe try the Desktop application to add a new WIFI.
  • IIRC there was an issue back with the Fenix 3 where Garmin had just used the US WiFi channels in their hardware/firmware. Most of the world uses channels 1-13, but the US only allows 1-11, so that was all the f3 used. Most people have their WiFi routers set to automatically choose a channel with low congestion, and if your router chose a channel between 1-11 you were fine. However, if it chose (or later switched to) 12 or 13, your f3 would no longer work be able to see it. The fix was to select a channel manually (between 1-11) on the router. You were then usually OK to switch the router back to automatic channel selection, as if would probably stick with the channel you'd just selected manually unless it was heavily congested, and even then with a bit of luck it wouldn't switch back to 12 or 13.
    This was several years back though with the original Fenix 3, so I'd have hoped Garmin would have fixed this by now. However, this is Garmin we're talking about and the symptoms do sound similar, so it might be worth trying a channel change on your router, if only to rule out the possibility.
  • Can't add much to the post above except to say I'm up in the Southern Hemisphere and have my 5+ connected to several WiFi networks at home, at work and even a couple of free ones in the city and the supermarket. All work fine. Maybe have a chat with Garmin Support as it is possible there could be an underlying problem.
  • I tried Garmin Express, and I have added the network (strangely, I have managed to see it only after watch reset). But now after attempts to connect to it watch freezes (with "searching for network" message), which is what I have experienced in the past when I was trying to connect to earlier defined network, and also when I removed it (for troubleshooting purposes) and added it manually (on the watch).
    I cannot set channels manually on my WiFi mesh, but I doubt this a issue as I tried to find ANY network in multiple different locations, where many different networks where available (and visible to both laptop and smartphone) and watch seen nothing.
    Seems I have to open ticket at support :-( This worries me cause before someone will attempt actual troubleshooting, I will have to go through usual level 1 bullshit ("have you tried to turn it off and on again?").
  • That's really interesting - I have opened ticket at Garmin Support and next day I see new beta FW release 6.58 with only one update:
    • Fixed an intermittent issue where one was not able to connect to Wifi after a powercycle.
    I wonder if I triggered it :-)
  • I was also hopeful the 6.58 update would fix wifi problems.
    My watch can connect to wifi only once when I add a new network, but gives a "incorrect password" message when I try to connect again to the same network.
    As a result I am not able to get my spotify playlists to the fenix 5+ music
    Hope it will be fixed soon since the spotify playlist addition was one of the reasons to choose this model :-(
  • Garmin asked me (no surprise here) to wipe entire configuration and re-install firmware. I'm about to start 2 week trip without access to PC, so I will skip it for now just to avoid problems before trip start. Hope that in the meantime FW 7.0 will be released and this will fix the Wifi as well (and maybe bring some MARQ goodies as well :-)
  • I have a similar issue when trying to connect my Fenix 5 to my home WiFi network for the first time. Using the watch settings failed to find any networks however, using the Garmin Connect App on my phone worked quite quickly. Then, my watch recognised the network.
  • I did all the wipes and reinstall as Garmin Support suggested. Meanwhile also updated to 7.10 - no success at all. Garmin have asked me to send the watch to them, but I hesitate, as I know Poland reality and I anticipate that it will take weeks to get watch back - and I use it daily. 

    Meanwhile I have found another topic on this forum which is describing EXACTLY same symptoms. So to be specific - my WiFi version says 655.35 - which FF.FF in hex - seems wrong, it should be 2.50. I have tried the method described there -so I have tried to put the GUP2196.GCD file (from latest beta) manually into GARMIN\RemoteSW - but no sucess - after reboot the WiFi version stays 655.35. Also - spotted that once connected to Garmin Express the gup2196.gcd appears in GARMIN\RemoteSW - but does not seems to be installed.

    Any ideas how to force watch to update/fix the WiFi driver - which I suspect is the root cause of the problems? 

  • I have decided to attempt force watch to install Wifi driver by installing full beta (7.52). I have performed all the steps described here 


    and 7.52 was successfully installed. During installation it even listed (in Polish, I'm using Polish language on watch) that it install OS updates, sensor hub update, ANT/BLE, GPS - but nothing on WiFi.  

    As anticipated - WiFi version remained 655.35 and WiFi connectivity is not working. Any ideas how to force WiFi firmware update?