USB Mass Storage not working

I just got the Fenix 5X Plus (titanium) and it refuses to mount as Mass Storage Device.
I have tried with two Macs and two cables.
The 5X that I still have is working with both Macs and both cables.

Garmin Express will recognise the 5X Plus and transfer updates, music, CIQ stuff, etc. just fine with good speed.
But no drive mounted on the computer for manual transfer of beta, maps, etc.
Both computers can see the device "composite" in the System Information app but none of them will see it in Disk Manager (or whatever it's called on English systems.

Any clues, solutions?
  • @RunR - Thank You, the option "follow course" is a good point to remember. Will this still allow turn-by-turn notifications? I think it works on newer devices (with the NextFork function) but on older devices, there is only an "off course" alert, because the turn directions are calculated via the map, not from the GPX data... correct?

    And last not least, the bike navigation devices do not exactly behave like the watches, which also adds some confusion to the subject matter.

  • because the turn directions are calculated via the map, not from the GPX data... correct?

    Turn by turn does not work with GPX files themselves. RunR has already described that you need a FIT file on the watch. Either you import a FIT file directly to the watch, or you create a route in Connect. Or you import a GPX file in Connect and send the route with Connect to the watch. In this case, Connect converts the route into a FIT.

  • As I wrote before the alerts come with the track, but be aware that when you directly copy .gpx files from a PC to the watch, they are lost. Fit or GC are the options that work. It worked the same way on a Fenix 3 and afaIk it is similar on newer watches.

    I never use "use map" because it takes ages to calculate the track in the beginning of an activity and I don't want a recalculation when Ieave the track for a short distance.