GPSMAP 86Sci microSD Card Slot Problem?

***All Firmware Updates Applied As of 5/29/2020***


I recently purchased a new GPSMAP 86sci.   Bought it from and have completely positive things to say about their service.

That said, I've been having a bit of a problem with the unit reading a fairly new, Class 10, 32gb Sandisk MicroSD Card, when the card is in the unit and the usb cord is connected to my laptop.  (Asus G50Vt, Win7, new Samsung 500GB solid state hard drive.)

The card reads fine in my computer's SD Card port, using a full-size SD Card Adapter.  I tried another card from my older eTrex Vista HCx--a PNY 2GB regular speed card--and it works find when in the GPS slot and connected to the laptop.

The newer card worked when I first powered up the gps and connected it to the laptop, but hasn't worked after that, except in the laptop port.

I formatted the card to FAT32, Default Allocation Size.

Another issue I have is that my maps from the GPS File Depot web site (Michigan Topo, MyTrails, etc.) work fine when I load them on the unit's internal memory, but won't show up when I put them on the micro sd card.  My Vista HCx works fine this way, so I'm wondering if this is a micro sd slot that's out of tolerance by a few Tenths of a Thou (Top-To-Bottom), or a bad read system (either on-board bad etch traces, improperly coated card contacts, firmware, or a combination of these.)

I had purchased a 66i, and it ended up having a compass module that was off by about 28 degrees from center.  I returned that one, and exchanged it for the 86sci, which I like better, but now I may have a bad card port.  Maps sent to the micro sd card on the computer should be able to be read by the 86sci.

My main concern is that I want to by a commercial mapping product that shows plat lines and property ownership, and it uses the sd card port for it's product.  If the card they use won't be read by the 86sci, then I'm out expensive mapping products.  The product is by a recognized Garmin Devleloper.

As to quality control on these inReach/Nav units, I'm beginning to lose my faith.  I've used the aforementioned 32gb SD Card in a couple of phones, so I know it works.  It can be read by my computer.

As a litmus test, I also plugged the GPS into my computer on my ubuntu linux OS, which I have on another partition on the same laptop.  The 2gb card out of the Vista HCx worked flawlessly when in the unit and connected with the usb cable, showing up on the linux side, while the 32gb card--when in the same configuration--didn't show up at all.  The 32db card also showed up in the card reader on the laptop on the linux side.

I"m guessing it's a slightly out-of-tolerance card slot.

Thoughts and Suggestions are welcome.

Thank You,

Mr. Stephen A. Brown

Indian River, Michigan


[email protected]

  • Best bet is to open a call with Garmin tech support. 

    Failure to index the card (so that the maps on it are visible on the unit) can be issue. That typically has a solution which I unfortunately do not remember. However, failure to read the card when connected to a PC which can see/read the internal memory file system does suggest a hardware issue.