Software 6.20 Scorecard Issue

I recently updated my S42 to v6.20 and used it out on the course today. I've found that when scoring and a number is entered for a hole it does not seem to get on to the scorecard. I had to edit the scorecard each time and add the score manually there as well.

Anyone else suffering from this and know of any resolutiions yet?



  • Played yesterday, and the watch worked fine - suspect a fix was sent down since last time as it now alerts me with 2 buzzes every time I walk to the the next Tee and when I enter the score it appears in the scorecard with no issues.

  • That's interesting. I've just tried updating my S42 in Garmin Express and it doesn't offer a software version beyond 6.20 - the one causing the problems. What version are you on?

    And what settings have you selected; perhaps the watch behaviour is sensitive to them for some reason? e.g. I have Stableford set up as the scoring method in the golf settings

  • Still showing as 6.20, but that's not to say that Garmin haven't sent a fixed version of 6.20 rather than increasing the version

  • Have tried to see if I can force version 6.20 to load to the watch again but Garmin Express doesn't seem to offer that option. Used my watch out on the course again today and it's still showing the same fault.

    I have had a response back from Garmin Support but it's very early days yet with no indication so far on how the fault is to be resolved.

  • Maybe it's specific to your watch. Mine is the S40 I believe

  • I just did a total reset on my S42 and deleted all the data after I made sure it was synced to my computer so I did not lose anything. Went thru the whole process and added it back into my phone and redid all the settings.  Not playing until Thursday,  I am curious if that will fix it.  Somehow I doubt it but I am giving it a shot. It still showed version 6.20 on the watch when I hooked it back up to the computer.  But at least the internal memory is cleaned out now.  I also updated my S20. I had just done that last week but there were new updates for it. I also powered it off and back on again. Doubt there is much more I can do to it to clean it up. 

  • The one thing I hadn't tried was a reset to defaults including deleting the data. So having backed the S42 up again recently I'll now try the full reset & delete and see how it behaves during a game I have on Thursday too.

  • No change. Did the same thing. Waited until I got to the next tee box.  Entered the score and then checked the score card and it was missing. Had to reenter it again just like before.  So something in the software update hosed it.

  • And the same for me as well, no change from the previous faulty behaviour. I took a short video clip of the issue today and have sent it as part of the evidence in connection with the Garmin Support call I have open at the moment.

  • Heck I did not even think of doing that. Good job. Our course was busy today but I doubt I would have thought of that.  I am ready for them to fix this mess. Or give us instructions on how to back out of 6.20 until something is fixed. Other than not retaining the score it is working fine.  Why bother asking me what my score was if it is only kidding that it will actually record it. Thanks for opening the support call.  If they need another reference I will be glad to chime in.