Announcement

Collapse
No announcement yet.

Problem with the loading cable

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Problem with the loading cable

    I received my 5x yesterday. Unfortunately I have problems with the loading cable. The connection to the PC is not stable and need to bend the cable slightly at the connector to the watch. Has anyone have similar problems?
    Garmin Support will send a new cable and i hope it solves the problem and there is no defect at the connector of the watch.
    By the way I am not very happy with the new design of the connector as dirt will get in there quite easy. A plastic cap would be nice to cover it.
    All the best
    wolf
    Currently own: Fenix 5X | Fenix 3HR
    Vivoactive HR | SDM4 | HRM-TRI | HRM-RUN | HRM-SWIM | Tempe Sensor | Speed and Cadence Sensor

  • #2
    Same problem for me ;-(

    Comment


    • #3
      No cable problems here.....

      Comment


      • #4
        The same problem for me...
        What do you think?
        Is it the cable or connector?

        Comment


        • #5
          I have the same problem. The connection to the PC is not stable and fenix 5x is disconnected after few seconds.

          Comment


          • #6
            I have the same problem connection goes crazy all the time.

            Comment


            • #7
              Same here

              Comment


              • #8
                same for me

                Comment


                • #9
                  I have contacted Garmin Support. And they are supposed to send me a new cable. I hope it will fix the problem

                  Comment


                  • #10
                    I would be very interested if the Exchange of the cable will fix the Problem. I will keep you informed if it works for me es soon as the new cable arrives.
                    Currently own: Fenix 5X | Fenix 3HR
                    Vivoactive HR | SDM4 | HRM-TRI | HRM-RUN | HRM-SWIM | Tempe Sensor | Speed and Cadence Sensor

                    Comment


                    • #11
                      Originally posted by wolf04 View Post
                      I would be very interested if the Exchange of the cable will fix the Problem. I will keep you informed if it works for me es soon as the new cable arrives.
                      Thank you

                      Comment


                      • #12
                        The problem seem to be solved.
                        I connect to another PC without garmin express.
                        Then to the PC with Garmin Express and the connection is stable.
                        Also in general settings in GE, both a check mark.

                        Comment


                        • #13
                          Hi Lee
                          I tried this but in my case unfortunately its not working. The Problems stay the same. I am looking forward to the new cable.
                          Cross fingers that this will solve the issue and I donĀ“t have to send back the 5x....
                          All the best
                          wolf
                          Currently own: Fenix 5X | Fenix 3HR
                          Vivoactive HR | SDM4 | HRM-TRI | HRM-RUN | HRM-SWIM | Tempe Sensor | Speed and Cadence Sensor

                          Comment


                          • #14
                            intermittent cable connection

                            Same issue with the connection cable. Let us know if the replacement cable fixes the issue when it arrives please.

                            Comment


                            • #15
                              heras 21002

                              I also experienced this few times .... let us know if new cable solves issue - hope is not (another) watch issue.

                              Comment

                              Working...
                              X