Announcement

Collapse
No announcement yet.

Fenix 5 Plus - Wifi Broken?

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Fenix 5 Plus - Wifi Broken?

    Hi,

    Today i finally recieved my new Garmin Fenix 5+
    I wanted to install Spotify and it told me it needed a software update. I updated to 6.00 using Express.
    I was able to install the Spotify app, but the watch gives me a huge headache when trying to setup Wi-Fi.
    Literally tried everything. Express, Connect. Automatic search does not find a single network (does not even list), a manually setup network freezes the watch (needs a hard reset then) when trying to connect.
    I then had a look into the about dialog and it shows:

    GPS: 2:30
    WIFI: 655.35 (shouldn't that show 2.50; at least it said it updates to 2.50)
    CIQ: 3.0.4
    WHR: 20.03.32
    ANT/BLE/BT: 3.20
    Sensor Hub: 2.30

    Does someone has any idea how I can fix this?

    Pretty annoyed, as all of the 5 Garmin watches I had before worked flawlessly and this one was by far the most expensive one.

    Thanks!


  • #2
    Yep, the version number is encoded in 2 bytes and "FF FF" would be 655.35. Looks a bit like your WiFi firmware was erased but no new firmware was installed. Have you tried to reinstall the GUP2196.GCD from the latest beta package (put the file from the WiFi_v250 folder into the "GARMIN\RemoteSW" directory on your watch)?
    I can make my fenix 5 Plus think it's a D2 Delta…

    Comment


    • #3
      Yes i tried that. I put the fle in there but it seems it's not picking it up.
      I now tried to revert to 5.10 and reupdate to 6.00.
      In 5.10 it shows Wifi 2.50 and wifi networks can be listed. As soon as i update to 6.00 it messes it up again.
      I tried to revert again to 5.10 and it didn't fix it on second attempt. Updated to 6.00 again and still messed up (see attached picture).
      Very, very frustrating as it's not clear how it is behaving...
      Last edited by kerthi88; 12-09-2018, 01:33 AM.

      Comment


      • #4
        Found out that as soon as i hook up the watch to garmin express the gup2196.gcd is automatically placed into Garmin/RemoteSW. So it seems express realizes that something is missing. But it's never installed correctly.

        Comment

        Working...
        X