Announcement

Collapse
No announcement yet.

Explore App with Fenix 5

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Explore App with Fenix 5

    Is the Explore App supposed to be working with my Fenix 5 yet? I emailed the beta team a month ago and was told to log a support call. They said 'it is in beta'. So not really an answer. Fenix 5 not listed on device page of Explore App. It is visible at explore.garmin.com. Just installed this beta, as I have every previous release of any type, still not there.
    Last edited by seilogramp; 12-21-2018, 12:53 PM. Reason: Moved post to Forum - On the Trail - Explore - Explore App Android

  • #2
    It isn't only supposed to be working with your Fenix 5, it is working for over a month now. If you open the app and just be a little curios and go one step further, you will see it is working.
    By the way: this is a question for the Explore App forum.

    Comment


    • #3
      Garmin Explore App Compatible Devices

      The following devices are compatible with the Explore App:
      • fenix 5 Series*
      • fenix 5 Plus Series*
      • fenix Chronos*
      • forerunner 935*
      • GPSMAP 66 Series
      • Instinct
      • quatix 5*
      • tactix Charlie*
      * These products are currently in beta testing and although this software is believed to be reliable, you may still encounter an occasional issue.
      myConnect | StravaHeatmap
      F201 | F205 | F305 | 310XT | 920XT | HRM4-Run
      nüvi 1300 | nüvi 52 | nüvi 67 | Drive 61 | Dash Cam 45

      Comment


      • #4
        I have removed watch from phone/gc app, readded to phone. Master reset watch. Removed Explore app, reinstalled Explore app, tried with a different phone. Contacted beta team, raised support ticket. Created account at explore.garmin.com - fenix 5 appears there. Create routes, imported routes - they come to phone.

        In Explore app, clicked on Devices, I see 'MYNAME sync today...' below is says PAIRED DEVICES and below that + Pair Device. Below that it says 'No paired devices'. I click on + Pair Device and it says 'Pair a device with the Garmin Explore, or register a new device'. Below that are two options Register Device with Garmin Connect and a link to Online Support (which loads a web page). I click on Register Device with Garmin Connect and it takes me to the Device page of Garmin Connect App showing my fenix 5 connected and syncing.

        I am very curious but without any result!

        Comment


        • #5
          i'm really annoyed...
          i have fenix 5x and fenix 5x plusdisplayed
          installed on:
          sony xperia z1 compact android 5.1.1 no devices displayed
          sony xperia z3 compact tablet android 6.0.1 no devices displayed
          sony xperia xz2 compact android 9.0 no devices displayed (my current phone)
          huawei mediapad m5 android 8.0 no devices displayed
          samsung j7 android 7.0 no devices displayed

          it only works with iphone 6 ios 12

          Comment


          • #6
            Here same problem trying to connect my 5x plus but no success. Tried uninstalling the app several times but with no luck. Now I also got an error during synchronizing..
            Last edited by Hopjesvla; 12-30-2018, 03:17 AM.

            Comment


            • #7
              No one has a clue? tried same things as TrippyZ, though the difference is that on the Explore site i don't see my 5X listed. This might something have to do with the fact that the app doesn't synchronize with the site (i get an synchronization error) but still, tried uninstalling, clear cache, change passwords etc. but with no luck.

              Comment


              • #8
                SOLVED. I logged a ticket for this but the responses have been useless and going round in circles asking the same questions.

                This is how I solved the problem. Bear with me because the solution is completely nuts!

                My girlfriend has the Garmin Connect app on her Motorola with a vivofit device registered.
                I installed Explore onto her phone and logged into the Explore App on her phone as myself.
                I could instantly tell that things were different with several different screens appearing and my Fenix showing under the Pair Device option.
                I fired up Explore on my phone to find that my Fenix was now appearing under the Pair Device option.
                Incredible and bonkers!
                Last edited by TrippyZ; 02-11-2019, 03:14 AM.

                Comment


                • #9
                  Tried the option of TrippyZ, but still no luck...

                  Comment

                  Working...
                  X